Home Assistant breaking on Raspberry pi 4 after plugging in sonoff usb donble

While you are at it, follow the general tips in https://github.com/home-assistant/home-assistant.io/pull/18864 and https://www.home-assistant.io/integrations/zha#best-practices-to-avoid-pairingconnection-difficulties as all Zigbee Coordinator adapters is very sensitive to EMI/RFI interference (e.g. a noisy radio frequency environment will jam the signal and prevent it from receiving all Zigbee messages to it without errors).

PS: If it help give a thumbs up in https://github.com/home-assistant/home-assistant.io/pull/18864

It’s work for me too without extension cable for the moment.
I just stop my Raspberry, plug the dongle and start my Raspberry and it’s ok…
Before I tried without stop the raspberry, I think that was the problem.

I had the same issue: only SSD works fine, inserting sonoff dongle resulted in the error message “Error: network commissioning timed out - most likely network with the same panId or extendedPanId already exists nearby” in the zigbee2mqtt log files.
Checking the link in the log file (Zigbee2MQTT fails to start | Zigbee2MQTT) this would refer to a power issue with the advice to use an external powered hub for the SSD.
I tried the extension cable for the sonoff dongle as opt-ed by several people, and I can confirm this solved the issue for me.

1 Like

Can also confirm this worked. I used a USB hub with powered by another powerbrick (because I didn’t have a usb cable extension)

that was my problem too. The screws are so tight. I cracked them with sheer willpower.
Supposedly there is a way to put it in bootloader mode with a linux program without pushing the button.

Def update the firmware to the 1217 version.

See → ITead's "Sonoff Zigbee 3.0 USB Dongle Plus" based on Texas Instruments CC2652P +20dBm radio MCU now sold for $14.99