Home Assistant breaking on Raspberry pi 4 after plugging in sonoff usb donble


I’m running Home Assistant off an Raspberry Pi 4 booting from an ssd.

I recently purchased the sonoff usb dongle 3 and when I plug it in, nothing seems to happen, and i can’t detect it using the ZHA integration.

Soon after, I can’t access the integrations page or and integrations, and slowly everything starts failing.

If I unplug the dongle and reboot, it seems to work properly again. Any ideas about what’s happening?


Have you tried a USB extension? Different USB port?

Mine works with no issue.
As @fenty17 mentioned you may need an extension cable. EMI is a real with USB3 and other devices plugged into other ports. You could have a power issue? Not sure what powered supply you have?

I have my SSD on a powered hub on an extension cable plugged into a usb3 port. My sonoff dongle is on another extension cable plugged in to a USB2 port.

I’ve just ordered for an extension, let’s see if it helps. I’m using the raspberry pi power supply and have an ssd (Crucial bx 500) that is powered through usb by the raspberry pi.

I am able to detect the dongle on my windows pc so it’s not really a dongle issue i think. I’ll update once i try with the extension cable.

The Sonoff specs are only 100 ma. If you are using the recommended power supply you should be fine. Are there any other devices connected?

No, no other devices. Just the ethernet cable and the ssd through the usb 3.0 port. Its not super hot or anything.

Its very weird, once i plug it in, most of the Home Assistant pages don’t load or give errors. I cant reboot it from the web page as well, have to manually diconnect power and reconnect. I though it might be a boot order issue but that doesn’t make sense as even when I plug it in after booting, it causes an issue.

I have exactly the same problem with the same errors with the USB3 port and this dongle.
I have not tried yet to plug it on the USB2 port.
I think I will flash and update the dongle with this video:

What do you think about this ?

I was planning on flashing it, but I don’t have a screwdriver small enough to open the screws :smiley:

Are you guys plugging it into the USB3 port? EMI issues with both devices so close. Most people are having issues without an extension cable. Intel published a white paper on EMI caused by the USB3 switching. It interferes at the 2.4 GHz that the Zigbee uses.

my sonoff is plugged into usb2 which is adjacent to usb 3.0 used for my hdd. I’ll wait till my extension arrives and update if it works. I’m in australia so deliveries take a lot of time :smiley:

Yes. Recommended.

I re-read your issue. The cable will help for EMI. I don’t believe that is your issue. EMI causes issues with zigbee, not with the pi not working.

What is the rating of your power supply? The official supply is rated at 5.1V 3A (15.3 W).

You may want to creat an issue on GitHub and post your logs so one of the developers maybe able to help.

There is another good reason for needing a USB extension cable and that is the USB plug on the dongle is very short so could be that if have an Raspberry Pi enclosure that is hindering the USB plug part of the dongle to be properly inserted all the way in the Raspberry Pi will not detect it since it is not actually fully plugged in. Using a USB extension cable with a longer USB plug part should help that issue.

Se alternative upgrade method here which does not require removing any screws or opening the case:


However, I do not believe that updated firmware will help with the symptoms described as it sounds like the issue is that the Raspberry Pi is not physically detecting the dongle for whatever reason.

He said that " can’t access integrations and … everything starts failing. This is not a zigbee issue unless the dongle is drawing more power than his supply can handle. I can’t tell from his comments if the dongle is inserted properly. This should not be an issue with “most” cases.

FYI, automatic USB discovery for ZHA will not work on early shipped batches of ITead Sonoff Zigbee Dongle Plus adapters unless you write missing custom product description in its CP2102N USB chip:



Even the discovery through the integration does not seem to work. Will update with results tomorrow.

This might be it. I have a feeling the USB is not going in. the 2 middle pins on the dongle don’t seem to be full length

I think it’s normal.
Here is a screenshot of the video that’s update the dongle.

Again, use a long USB extension cable with a thin port so that the thickness of the computer enclosure casing does not prevent dongle from being plugged in all the way into the port on the computer board.

It is as well very strongly recommended to use a long USB extension cable to avoid EMF interference.


Also follow general tips in https://github.com/home-assistant/home-assistant.io/pull/18864 and https://www.home-assistant.io/integrations/zha#best-practices-to-avoid-pairingconnection-difficulties as all Zigbee Coordinator adapters is very sensitive to EMI/RFI interference (e.g. a noisy radio frequency environment will jam the signal and prevent it from receiving all Zigbee messages to it without errors).

Using a longer USB extension cable to connect any radio adapters using the 2.4GHz frequency range to a USB 2.0 port (or a USB 2.0 hub) is step #1 and step #2 to try to avoid EMF/EMI/RMI interference.

Take note that the dongle is every big/wide and some computer enclosures are thick and do not have a lot of room around the USB ports, and if so then you need a USB extension cable which port is thinner.

Such computer enclosure casings will put the USB port a little bit recessed which can cause issues.

One such known example is the Home Assistant Blue enclosure which has issues with its thick casing:

This was perfect. It’s working now - my case was blocking the dongle from being inserted properly. I’m such a goose, but hope this helps someone out with a similar problem.