Home Assistant Cloud (Nabu Casa) Dissapeared from the configuraton menu?


I have successfully managed to install my Home assistant supervisor setup under docker on my Mac Mini with Ubuntu LTS 14.04, and I’m also able to install official add-ons from supervisor.

The first day I was able to connect my setup to Nabu Casa cloud from the configurator tab in the left menu, but today this option disappeared?

I tried to look around here on the forum and also on google, but with no luck.

1 Like

i have the same problem

I’m assuming you mean something other than 14.04, as that’s over 6 years old at this point.

First off, check to make sure you have
in your configuration.yaml. It’s should have already been there by default, but ya never know…

At any rate I hate to tell you this, but the best solution for your long-term sanity will be to re-install, using Debian instead of Ubuntu. Ubuntu is becoming less supported with every release and more problems contribute to surface.

I ran the same setup as you -Supervised HA on top of Ubuntu 18.04 on a 2012 Mac Mini. I got tired of the warnings and strange problems with each new release and finally just rebuilt with Debian 10. It’s now a flawless experience.


Im using the Core Version. I dont have that “cloud:” in my configuration but I still can see it.
Tbh, I would like to get rid of it, since I dont want to use it.

Thanks for your reply Terry,

I wasn’t thinking much about my OS since I’ve been running my Mac mini setup with 14.04 for at least 4 years already.

I will try what you suggested by changing to Debian (though might do this on another HW).

I did have “cloud:” in my config btw.


I’m surprised other issues haven’t surfaced before now with 14.04. I can’t be sure this is related but it wouldn’t surprise me. It was a good release though, I ran it myself for years.

Debian 10 is a painless install on the Mini, and runs beautifully on it.

The only other time I’ve personally experienced your specific problem was after a power blip. The power went off, on, off, on in the span of a second or two. Despite the mini being plugged into a UPS, the mini restarted. HA came back seemingly fine, but I had no cloud connection and it wasn’t an option on the Configuration page. Everything else seemed normal. I powered off the mini, booted from a usb stick and did a fsck on the drive. Rebooted when it was finished and magically the cloud was back. It’s hard to imagine how that could cause such a specific error, or that the resolution would be a clean power down and file system check, but that was the only thing I did and it worked afterwards…


I followed your suggestion by installing Debian 10 on my mac mini.
It all went flawlessly and had HA up and running in no time, used my snapshot and all seems to be working fine already, I can now also see the cloud under configuration and connect and use the cloud as intended.

Now I’m able to monitor my solar plant and water pumps here in the jungle when I’m not around lol


1 Like

I don’t suppose you have a link to a guide or something do you? I’m trying to convince a mate to jump into Home Assistant but he is fixated on using a Mac which I have zero experience with. He has tried once but it failed somehow (not sure which instructions he followed) so if you have something that works, that would be great.



It’s basically just like installing on any other computer.

  1. Create a bootable install CD/DVD or USB drive.
  2. Insert #1 into the Mac Mini
  3. Power-on WHILE HOLDING DOWN the Option key
  4. Select the boot device from #1
  5. Install as you normally would.

NOTE: This is only for older Minis (max circa 2014ish I believe) as the new devices have an Apple security chip that will not allow the install of an alternate OS on the main drive. You can however install on an external USB drive and boot to that. I have a 2012 i5 Mini with an SSD and 16gb of ram and it’s a beast on Linux. Those years are very affordable on the used market these days and are the last ones that have user-upgradable memory and drives.


1 Like

Hi Dave,

No, I didn’t create any guide, I did as Terry explained above, it is really straight forward and wouldn’t require any special knowledge except following the onscreen instructions that Debian installer will provide.

However, if you refer to the docker + HA installation, I followed this guide:


1 Like