Home Assistant Community Add-on: AdGuard Home

Tags: #<Tag:0x00007fc3fdc8ce68> #<Tag:0x00007fc3fdc8ccb0>

This is so weird. Setting it to Google DNS works without issues.
But setting them to my dns servers afterwards bugs out after a while again until I tell my router to use its own dns servers again and then go back to adguard home dns again. So for now I can only use Google DNS inside Adguard Home.

Are there special instructions for installing this on Home Assistant Operating System on Raspberry PI?
I have the following configuration:

  • Core: 2021.5.2
  • Supervisor: 2021.04.3
  • OS: Home Assistant OS 5.13

On attempting to install this using ConfigurationIntegrationsAdd Integration, I’m greeted with a screen requesting credentials. In the past when I installed this addon inside of hassio running on top of raspbian via docker, it was simple. However, now that I’m running Home Assistant OS, i’m stuck.

I tried to install the Adguard binaries after using the Terminal & SSH Add-on to connect to the raspberrypi. Once installed and running, it says that the service is available at 127.0.0.1:3000, along with an IP address that looks like it relates to docker (172.30.xxx.xxx). When running ifconfig in the terminal, I see the ethernet interface along with localhost. However, I use wifi to connect the raspberrypi to the network. Any suggestions on how to proceed?

Hi! Actually, the integration is used to connect a pre-existing adguard home installation to HA. You need first to install the addon by going in Supervisor → Store → Search Adguard Home.

If you don’t find it, it’s because the repository is not installed. To install it, click on the three dots at top right, then Repo (or equivalent in your language), and add “GitHub - hassio-addons/repository: Home Assistant Community Add-ons”.

Once adguard home is installed, you simply start it then click on “open webui” and follow instructions.

Installing and running it from “Terminal & SSH addon” won’t work as it will install it within this container. Honestly, Home Assistant OS is very simple to use, it’s plug & play. Anything more than plug & play is actually rather complex as the OS can’t be easily accessed and is anyway mostly read only.

1 Like

I loose internet connection whenever I use my Home Assistant IP address as a preferred DNS server in my Asus AC86U settings. This only recently started happening. Is this the same issue you are describing? If so should I change the address below to 8.8.8.8

Is there a way i can set custom DHCP options similar to
dhcp-option=121, .0.0.0/0,192.168.1.1,10.0.0.0/24,192.168.1.10

Hello there, recently I have an setup to take this AdGuard Home add-on one (tiny) step further - along with pixelserv.

The problem: with the adguard in place, from time to time you would see this gibberish when you browse an website. Here’s an example when I use Google News:


While it’s fine and harmless as is, wouldn’t it be great to get rid of those?

The process
So I searched around, and realized that there is a project called pixelserv-tls out there.

And, then, there’s even a docker for this with the image size at just 7.6MB!! And even better for my HAOS-VM-inside-a-linux-box-with-intel-CPU setup, the docker is compatible to my setup.
https://hub.docker.com/r/imthai/pixelserv-tls

So the solution:

  1. I use the portainer add-on, which is also by frenck, pull the docker image, setup the ports, and deploy!
  2. Check the docker. If it is working you should see a blank page.
  3. Change the AdGuard DNS settings and point it to the ip of HAOS, using the “Custom IP” option.
    Screenshot 2021-05-17 121308
  4. Done!

So most of the time is for me to read read read trying to know what need to be done. The time to actually implement this? It took me like 5 minutes only, and now the gibberish is gone!

Anyways, just want to share. I was lucky that my first attempt was a successful one.

1 Like

Have a look here. Seems a few have asked but not sure if there is an answer dhcp option 121 adguard - Google Search

Yeah I had a quick Google, that’s where my copy and paste came from, just wasnt sure how to integrate this in to the home assistant version

From my glance at DHCP · AdguardTeam/AdGuardHome Wiki · GitHub and Configuration · AdguardTeam/AdGuardHome Wiki · GitHub it looks like you might have to edit the AdGuardHome.yaml file. To do this I assume you will have to log into the underlying HASSOS and get into the adguard container. Info on how to do that is here Debugging the Home Assistant Operating System | Home Assistant Developer Docs

Hope that helps if not …sorry!

I upgraded from version 4.1.0 to 4.1.2 and now AdGuard doesn’t start. It was working fine before the update.

I am running the latest version of HA on a Rpi4. Below is the log, it crashes and starts over and over again.

[23:15:52] INFO: Starting AdGuard Home server...
2021/05/19 23:15:52.266323 [info] AdGuard Home, version v0.106.3
2021/05/19 23:15:52.279794 [info] Initializing auth module: /data/adguard/data/sessions.db
2021/05/19 23:15:52.280101 [info] auth: initialized.  users:0  sessions:0
2021/05/19 23:15:52.280125 [info] Initialize web module
2021/05/19 23:15:52.321811 [info] Go to http://127.0.0.1:45158
2021/05/19 23:15:52.791422 [info] Starting the DNS proxy server
2021/05/19 23:15:52.791465 [info] Ratelimit is enabled and set to 20 rps
2021/05/19 23:15:52.791475 [info] The server is configured to refuse ANY requests
2021/05/19 23:15:52.791483 [info] DNS cache is enabled
2021/05/19 23:15:52.791494 [info] MaxGoroutines is set to 300
2021/05/19 23:15:52.791514 [info] Creating the UDP server socket
2021/05/19 23:15:52.791813 [info] Listening to udp://192.168.XX.XX:53
2021/05/19 23:15:52.791832 [info] Creating the UDP server socket
2021/05/19 23:15:52.801369 [fatal] couldn't start forwarding DNS server: couldn't listen to UDP socket, cause: listen udp [fe80::c009:c97f:37a3:94eb]:53: bind: invalid argument
3 Likes

Same issue here, I’ve opened an issue on Github Adguard broke in the last update · Issue #297 · hassio-addons/repository · GitHub

Same issue for me. Fortunately I saw this post and took a snapshot so I am back on 4.0.0. Is it possible to just upgrade to 4.1.0. I haven’t done that before?

Sames. Mine was at 4.0.0 and upgraded to 4.1.2. In my case it starts fine, but will not resolve and DNS requests. Had to roll-back to 4.0.0 and all is working again.

Same here. Why do never learn to uncheck the auto update!
[fatal] couldn’t start forwarding DNS server: couldn’t listen to UDP socket, cause: listen udp [fe80::b4c3:7b6a:39d1:1017]:53: bind: invalid argument

Seems the Github Issue got closed soon after it was created. I am getting the same problem. So I uninstalled it and reinstalled it and now I’m getting a different line causing an error:

[cont-init.d] adguard.sh: executing... 
/var/run/s6/etc/cont-init.d/adguard.sh: line 27: null: unbound variable
[cont-init.d] adguard.sh: exited 1.
[cont-finish.d] executing container finish scripts...

Same here, after auto-update:

couldn't start forwarding DNS server: couldn't listen to UDP socket, cause: listen udp [fe80::7d4d:3999:d4f2:5c2c]:53: bind: invalid argument.

Removed the addon and re-installed it, now giving:

[cont-init.d] adguard.sh: executing... 
/var/run/s6/etc/cont-init.d/adguard.sh: line 27: null: unbound variable
[cont-init.d] adguard.sh: exited 1.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] 99-message.sh: executing... 
-----------------------------------------------------------
                Oops! Something went wrong.

 We are so sorry, but something went terribly wrong when
 starting or running this add-on.
 
 Be sure to check the log above, line by line, for hints.
-----------------------------------------------------------
[cont-finish.d] 99-message.sh: exited 0.
[cont-finish.d] done.Same here, after auto-update:
couldn't start forwarding DNS server: couldn't listen to UDP socket, cause: listen udp [fe80::7d4d:3999:d4f2:5c2c]:53: bind: invalid argument.

Removed the addon and re-installed it, now giving:
[cont-init.d] adguard.sh: executing... 
/var/run/s6/etc/cont-init.d/adguard.sh: line 27: null: unbound variable
[cont-init.d] adguard.sh: exited 1.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] 99-message.sh: executing... 
-----------------------------------------------------------
                Oops! Something went wrong.

 We are so sorry, but something went terribly wrong when
 starting or running this add-on.
 
 Be sure to check the log above, line by line, for hints.
-----------------------------------------------------------
[cont-finish.d] 99-message.sh: exited 0.
[cont-finish.d] done.

Never have auto-update checked.

As a matter of interest, does the auto-update create a snapshot as it does (ask) for a manual update? If so roll back to the snapshot.

You do do nightly backups automatically; don’t you? :laughing:

Same here since last updat

Thank God for backups… Same issue here haha, restoring to previous version fixed it…

Version 4.0.0 works, 4.1.2 gets bad gateway error and won’t load

Same Problem here :sleepy:, screwed my entire HA OS installation, definetly disable auto-update from all add-ons