Home Assistant Community Add-on: Glances

Tags: #<Tag:0x00007f7397b5d968> #<Tag:0x00007f7397b5d670>

This add-on is provided by the Home Assistant Community Add-ons project.

GitHub Release GitLab CI Project Stage Project Maintenance

Supports armhf Architecture Supports armv7 Architecture Supports aarch64 Architecture Supports amd64 Architecture Supports i386 Architecture

Glances is a cross-platform system monitoring tool written in Python.

About


Glances is a cross-platform monitoring tool which aims to present a maximum of information in a minimum of space through a Web-based interface.

Glances can export all system statistics to InfluxDB, allowing you to look at all your system information and its behavior over time.

Installation


The installation of this add-on is pretty straightforward and not different in comparison to installing any other add-on.

  1. Search for the “Glances” add-on in the add-on store and install it.
  2. Disable “Protection mode” in the add-on panel.
  3. Start the “Glances” add-on.
  4. Check the logs of the “Glances” to see if everything went well.
  5. Click the “OPEN WEB UI” button take a glance at Glances.

:books: Please read the documentation for more information about the use and configuration of this add-on.

Support


You can always try to get support from the community here at the Home Assistant community forums, join the conversation!

Questions? You have several options to get them answered:

You could also open an issue on GitHub, in case you ran into a bug, or maybe you have an idea on improving the addon:

:information_source: At this moment our Home Assistant Community Add-ons Discord chat server and GitHub are our only official support channels. All others rely on community effort.

Repository on GitHub


Looking for more add-ons?


The primary goal of our add-ons project is to provide you (as a Home Assistant user) with additional, high quality, add-ons that allow you to take your automated home to the next level.

Check out some of our other add-ons in our Home Assistant Community Add-ons project.

7 Likes

About the author of this add-on

Hi there!

I am Franck Nijhof, and I have 30 years of programming experience, in many languages. I am using this experience to work on the Home Assistant project by giving back my knowledge and time to the open source community.

The add-on you are currently looking at right now was developed/packaged by me. It is not the only add-on I have created; there are many many more :wink:

However, I have a problem… I am an addict. A :coffee: addict that is. Lucky for you, I turn that C8H10N4O2 (caffeine molecule) into code (and add-ons)!

If you want to show your appreciation, consider supporting me for buying a cup of high octane wakey juice via one of the platforms below! :heart:

Sponsor Frenck via GitHub Sponsors

Support Frenck on Patreon

Enjoy your add-on, while I enjoy the brain juice. :coffee:

Thanks for all the :two_hearts:

…/Frenck

Join our Discord server Follow me on Twitter Flollow me on Instragram Follow me on GitHub Follow me on YouTube Follow me on Twitch patreon-icon

P.S.: In case you want to ask me a question: AMA (Ask Me Anything). Most of the time I am online at the Discord chat. (I go by @Frenck in there as well).

Just installed Glances add-on and I keep getting 502 Bad Gateway / nginx/1.14.2. I enabled ssl and gave a login/password in the config. When I go to the web ui, I am prompted for login credentials but then get the above error.

2019/02/05 21:54:37 [info] 13685#13685: *1 client closed connection while waiting for request, client: 192.168.86.203, server: 0.0.0.0:61208
2019/02/05 21:54:37 [info] 13685#13685: *2 client closed connection while waiting for request, client: 192.168.86.203, server: 0.0.0.0:61208
2019/02/05 21:54:37 [info] 13685#13685: *7 client closed connection while waiting for request, client: 192.168.86.203, server: 0.0.0.0:61208
2019/02/05 21:54:37 [info] 13685#13685: *6 client closed connection while waiting for request, client: 192.168.86.203, server: 0.0.0.0:61208
2019/02/05 21:54:39 [info] 13685#13685: *8 client closed connection while waiting for request, client: 192.168.86.203, server: 0.0.0.0:61208
2019/02/05 21:54:39 [info] 13685#13685: *9 client closed connection while waiting for request, client: 192.168.86.203, server: 0.0.0.0:61208
192.168.86.203 - - [05/Feb/2019:21:54:39 -0600] “GET / HTTP/1.1” 401 29 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36”
2019/02/05 21:54:49 [info] 13685#13685: *3 client closed connection while SSL handshaking, client: 192.168.86.203, server: 0.0.0.0:61208
2019/02/05 21:54:49 [info] 13685#13685: *11 [lua] ha-auth.lua:59: authenticate(): Authenticated user against Home Assistant., client: 192.168.86.203, server: _, request: “GET / HTTP/1.1”, host: “192.168.86.123:61208”
2019/02/05 21:54:49 [error] 13685#13685: *11 connect() failed (111: Connection refused) while connecting to upstream, client: 192.168.86.203, server: _, request: “GET / HTTP/1.1”, upstream: “http://127.0.0.1:61209/”, host: “192.168.86.123:61208”

Any ideas?

im getting an error that my kernel is too old?

https://hastebin.com/xufafajixo.rb

running the NUC image with latest hass.io version

I haven’t a clue where the user/password the HTTP prompt is wanting to login to the glances web GUI should be found or set?

use your login credentials from your home assistant frontend

1 Like

Works nice! Thank you!

Can you share your glances config settings?

2019/02/07 12:40:26 [warn] 28483#28483: *9 [lua] ha-auth.lua:65: authenticate(): Authentication against Home Assistant failed!, client: IP-Address-Client-accessing, server: _, request: "GET / HTTP/1.1", host: "10.90.11.100:61208"
IP-Address-Client-accessing - HA-User [07/Feb/2019:12:40:26 +1100] "GET / HTTP/1.1" 401 29 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36"

I am using my HA user to authenticate and also had to disable protection mode

EDIT: Restarted the add-on and it works. Weird.

David,
Does this add-on require having external access to HA?

Nope. I accessed via local ip

I have been running HA on RPI3 for about a year and spent the past 2 weeks working on getting HA running in docker on Ubuntu on an old laptop I had laying around. A lot of trial and error along the way but its running now on the laptop. Keep getting the 502 error when trying to run thru the laptop HA instance.
Just installed it on the RPI3 and it started right up with no issues.When trying to run it on the ubuntu/docker on/ the laptop, the logs are showing connection refused and shows an ip address of my desktop PC. Not sure how it could be blocking it.

What does the log show? (for the addon)

2019/02/06 19:51:14 [info] 23628#23628: *1 client closed connection while waiting for request, client: 192.168.86.203, server: 0.0.0.0:61208
2019/02/06 19:51:14 [info] 23628#23628: *2 client closed connection while waiting for request, client: 192.168.86.203, server: 0.0.0.0:61208
2019/02/06 19:51:14 [info] 23628#23628: *4 [lua] ha-auth.lua:59: authenticate(): Authenticated user against Home Assistant., client: 192.168.86.203, server: _, request: “GET / HTTP/1.1”, host: “192.168.86.123:61208”
2019/02/06 19:51:14 [error] 23628#23628: *4 connect() failed (111: Connection refused) while connecting to upstream, client: 192.168.86.203, server: _, request: “GET / HTTP/1.1”, upstream: “http://127.0.0.1:61209/”, host: “192.168.86.123:61208”
192.168.86.203 - dmoses [06/Feb/2019:19:51:14 -0600] “GET / HTTP/1.1” 502 575 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36”
2019/02/06 19:51:15 [error] 23628#23628: *4 connect() failed (111: Connection refused) while connecting to upstream, client: 192.168.86.203, server: _, request: “GET /favicon.ico HTTP/1.1”, upstream: “http://127.0.0.1:61209/favicon.ico”, host: “192.168.86.123:61208”, referrer: “https://192.168.86.123:61208/

192.168.86.203 is the address of my windows pc

You disabled protection and also re-started the addon? I was getting similar errors until I restarted the addon

Yes, even went as far as uninstalling, restarting homeassistant container, reinstalling and trying again several times. If I try to run it making no changes to the config at all, ssl “false”, default settings I get This site can’t be reached and this in the logs.
[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing…
Log level is set to INFO
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] 02-updates.sh: executing…

INFO: You are running the latest version of this add-on
[cont-init.d] 02-updates.sh: exited 0.
[cont-init.d] 10-requirements.sh: executing…
[cont-init.d] 10-requirements.sh: exited 0.
[cont-init.d] 11-docker.sh: executing…

INFO: Docker support has been enabled.
[cont-init.d] 11-docker.sh: exited 0.
[cont-init.d] 20-config.sh: executing…
[cont-init.d] 20-config.sh: exited 0.
[cont-init.d] 30-influxdb.sh: executing…
[cont-init.d] 30-influxdb.sh: exited 0.
[cont-init.d] 70-nginx.sh: executing…
[cont-init.d] 70-nginx.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
INFO: Starting Glances
INFO: Starting the NGINX daemon
2019/02/06 20:36:02 [notice] 32279#32279: using the “epoll” event method
2019/02/06 20:36:02 [notice] 32279#32279: nginx/1.14.2
2019/02/06 20:36:02 [notice] 32279#32279: OS: Linux 4.15.0-45-generic
2019/02/06 20:36:02 [notice] 32279#32279: getrlimit(RLIMIT_NOFILE): 1048576:1048576
2019/02/06 20:36:02 [notice] 32279#32279: start worker processes
2019/02/06 20:36:02 [notice] 32279#32279: start worker process 32342

If I go back to the config and set ssl “true” and restart I get, 502 Bad Gateway nginx/1.14.2
and this in the logs,

amd64 / Ubuntu 18.04.1 LTS / HA 0.87.0b6 / SU 143 / beta

[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing…
Log level is set to INFO
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] 02-updates.sh: executing…

INFO: You are running the latest version of this add-on
[cont-init.d] 02-updates.sh: exited 0.
[cont-init.d] 10-requirements.sh: executing…
[cont-init.d] 10-requirements.sh: exited 0.
[cont-init.d] 11-docker.sh: executing…

INFO: Docker support has been enabled.
[cont-init.d] 11-docker.sh: exited 0.
[cont-init.d] 20-config.sh: executing…
[cont-init.d] 20-config.sh: exited 0.
[cont-init.d] 30-influxdb.sh: executing…
[cont-init.d] 30-influxdb.sh: exited 0.
[cont-init.d] 70-nginx.sh: executing…
[cont-init.d] 70-nginx.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
INFO: Starting the NGINX daemon
INFO: Starting Glances
2019/02/06 20:42:50 [notice] 2243#2243: using the “epoll” event method
2019/02/06 20:42:50 [notice] 2243#2243: nginx/1.14.2
2019/02/06 20:42:50 [notice] 2243#2243: OS: Linux 4.15.0-45-generic
2019/02/06 20:42:50 [notice] 2243#2243: getrlimit(RLIMIT_NOFILE): 1048576:1048576
2019/02/06 20:42:50 [notice] 2243#2243: start worker processes
2019/02/06 20:42:50 [notice] 2243#2243: start worker process 2313
2019/02/06 20:43:08 [info] 2313#2313: *2 client closed connection while waiting for request, client: 192.168.86.203, server: 0.0.0.0:61208
2019/02/06 20:43:08 [info] 2313#2313: *1 client closed connection while waiting for request, client: 192.168.86.203, server: 0.0.0.0:61208
2019/02/06 20:43:08 [info] 2313#2313: *4 [lua] ha-auth.lua:59: authenticate(): Authenticated user against Home Assistant., client: 192.168.86.203, server: _, request: “GET / HTTP/1.1”, host: “192.168.86.123:61208”

So do you have ssl enabled? (I don’t)

I do, and when I true to go to web ui I get,

Click advanced / proceed and get 502 bad gateway again.

so https://192.168.86.123:61208?