Home Assistant Community Add-on: Node-RED

Hello. I am trying to create a flow which will send a Pushbullet notification to my phone once a sensor battery drops below 10%.

The flow is very simple. The only problem that I have is constructing the JSON message to be sent to the HA notify service, since it consists of strings + variables, therefore I use a function to put that in a msg.payload and pass that to the call service node.

As per the debug info everything to calling the service works fine. The call service works if I pass a string message, however if I put empty curly brackets to pass the msg.payload object as JSON message I get an API error that the message cannot be empty.

What am I doing wrong?


Did you find a fix for the error “Cannot find module ‘minipass’”?


We’ll kinda. The error occurs when you add node-red-contrib-chatbot in the addon configuration.
I removed it and added it via the palette manager. Now its working again.

Hey all, I’ve used this add on for a long time but after some system updates tonight (from Home Assistant 0.108…I think? to 0.111.4), Node Red no longer works. All the nodes are stuck on “connecting”, and the Node Red add-on’s log keeps repeating the following over and over after getting through all the startup stuff:

19 Jun 22:59:58 - [info] [server:Home Assistant] WebSocket Connecting http://supervisor/core

It just keeps repeating that and never stops.

I’ve tried:

  1. Updating the supervisor (now on version 227) and Host os (now on HassOS 4.10)
  2. Rebooting the server
  3. Updating Node-Red add-on to the latest version
  4. Changing the credential_secret to something else, starting the add-on, then changing it back (someone said this might work…it didn’t)
  5. Resetting the Node-Red add-on’s config to default (only changing my credential_secret back to what it was)

No effect. Since I’ve migrated nearly all my automations to Node-Red, this means my house is now dead in the water…my wife hasn’t touched certain light switches in so long she forgot how to turn off half the lights in the house. It’s chaos. SAVE ME.


Same here, node red cant get the list of entities in ha

could be an issue related to hassio not working fine: are other addons, if any, working fine / connecting to HA?
I had problems regarding nodered not connecting to HA and i solved it recreating the hassio_supervisor container ( if you have portainer is just a matter of stopping the container, click duplicate/edit icon and then click deploy ).
It could be anything else BTW, without knowing your environments and detailed logs it’s hard to point you in a direction.
About the log:

[info] [server:Home Assistant] WebSocket Connecting http://supervisor/core

make sure your home assistant is loading fine, i had this issue and the reason was a custom component ( in my case meross_cloud ): once i removed it and reboot nodered started to “talk” again with HA as soon as loaded completely.


If I include:

  - bartbutenaers/node-red-contrib-calc

in the configuration and the start up log reports:

[10:36:32] INFO: Starting installation of custom NPM/Node-RED packages...
+ [email protected]
added 1 package from 1 contributor and audited 959 packages in 59.853s
29 packages are looking for funding
  run `npm fund` for details
found 1 low severity vulnerability
  run `npm audit fix` to fix them, or `npm audit` for details

has the package been properly installed and if so where is it located? Looking in the Node-red folder in config I see the old version of the pallette

Screenshot 2020-06-30 at 11.02.17
Also, how would I uninstall this package?

I’m having an issue with the Ecobee integration, but only in Node-RED.

I’m trying to use the ecobee.resume_program service call to resume the current thermostat program after some windows being closed. I can see/call the service successfully in the HA service dev tool, but attempts to use it in a Node-RED call service node result in a debug window error message of:

“Call-service API error. Error Message: Service not found.”

I can use other Ecobee services in Node-RED service calls and they even populate the parameter hints properly at the bottom of the node properties editor. But with the ecobee.resume_program service, I don’t see any hints, all I see in the GUI is:

Service: Unknown Service.

Parameter hints are present for this service in the HA service dev tool, just not in Node-RED.

I know that the Ecobee stuff got caught up in the big Climate refactor a while back but it seems that just this specific service is just not being serviced / called properly in Node-RED.

Does anyone have any suggested debug paths or should I just log this as bug against Node-RED?

Running HA 0.111.4, HassOS 4.10, Supervisor 227 and Node Red v1.0.6.

Hi Y’all,

I’ve had a recent problem where I can’t get the right Timezone to show in Node Red. Home assistant has the correct timezone (as shown below) - I’ve also tried to update the config.js file for node red, as mentioned in the documentation.

I’m on Node Red version: 6.3.0

This happened after my last system upgrade. Any Ideas on what I should do? Searching hasn’t yielded any recommendations.

arch armv7l
chassis embedded
dev false
docker true
docker_version 19.03.8
hassio true
host_os HassOS 4.10
installation_type Home Assistant
os_name Linux
os_version 4.19.126-v7
python_version 3.7.7
supervisor 227
timezone America/Vancouver
version 0.111.4
virtualenv false

I’m using HA with the Node-RED add-on integration. What I’d like to do now is to change the server name to something other than the default “Home Assistant”.

My rationale is that, like many others, I’ve imported various flows to steal bits and pieces of flows and now have a Server name pulldown in node properties that consists of six “Home Assistants” and two "Hass.io"s. My server is the first “Home Assistant” but I’d like to make it something more unique. I’ve already chased my tail more than once because I had the wrong “Home Assistant” selected by accident.

Is there any way to change this and what would be the implication for my existing flows?

I’ve searched for the answer online but to no avail. Thanks in advance for for any help!

1 Like

Might sound like a really stupid question… please forgive… I just finished week 1 and approaching info overload. I prolly should have stuck to 2 or 3 topics, but everything was so cool and started to many projects… :wink:

Regarding Node-Red add-on in HA. I’ve followed some YouTube videos on creating a simple alexa-local flow. The question I have is on port usage. I am running the Synology native package from Fredricke and added the Node-Red addon. Versions are 0.111.4 & 6.3.0 respectively.

When I try and publish my node red flow, it wants to use port 80 which is used by my Synology. What port should I be trying/can use? I see where Alexa looks for port 80 and other Node Red addons state port 80 is mandatory and make sure its free. To do so on the Synology requires a hack (from what I’ve read using custom container files which disables the simplicity of the docker UI moving forward). I’ve also read on others alter the macvlan, again, something that seems to break Synology if done outside the UI.

I am using palettes: node-red-contrib-amazon-echo 0.1.10 & node-red-contrib-alexa-home-skill 0.1.17. Deciding on which to use so both are installed. the former I understand resolves the issues with certain Echo units.

Any advice and finger pointing to worthy articles is greatly appreciated.



While not a direct answer to your question, everytime you import a flow from someone, you put it through the Node-Red Scrubber. This will delete the other persons Server, as well as sensitive data like LAT and LONG data.

1 Like

Since addon update 7.0.0 I cannot “move” (scrol) via my android phone on the ha ap…

1 Like

Same for IOS

I updated to 7.0 today and can still scroll when accessing through my android phone and the ha app.

I do not mean scrolling through nodes but the configured nodes.

I’m not sure exactly what you mean by not through nodes but configured nodes.

I can scroll through my node pallette, I can scroll through my flows both up and down as well as left and right, and in case you were talking configuration nodes I pulled up the menu and can scroll through those as well.

I also noticed the scrolling issue.
In previous version you could touch the screen and move around. Right now I can’t find any scrolling function at all on Android mobile.
Will try a rollback to 6.4

1 Like

Yes! Exactly!

Zoom out and in works though.

Opened a ticket and got this answer just now:
“Looks like it is addressed in Node-Red 1.1.2 which was released yesterday. Will require an new add on release.”