Home Assistant Community Add-on: SSH & Web Terminal

Tags: #<Tag:0x00007fc4198886c0> #<Tag:0x00007fc4198885f8>

Just installed this on er fresh setup.
When I try to ssh [email protected] without the setup of a key, with the intention to log in with password i get the following response:

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @ @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY! Someone could be eavesdropping on you right now (man-in-the-middle attack)! It is also possible that a host key has just been changed. The fingerprint for the ED25519 key sent by the remote host is SHA256:2XzHvqyqb2hR+RPuvtnerl7BvXYNqd86fRr5cSFGzlV. Please contact your system administrator. Add correct host key in /home/User/.ssh/known_hosts to get rid of this message. Offending ECDSA key in /home/User/.ssh/known_hosts:8 ED25519 host key for 192.168.1.14 has changed and you have requested strict checking. Host key verification failed.

and the log says

Connection from 192.168.1.15 port 53442 on 192.168.1.14 port 22
Connection closed by 192.168.1.15 port 53442 [preauth]

And another note, don’t know if it’s the addon or Hassio, but the reset defaults button does nothing.

I also get this warning, although I just updated add-ons.

I’ve got the following error on this ssh and the terminal plugin. They don’t start anymore.
It’s a bit silly IMO XD. I have a raspberry pi zero btw.

[cont-init.d] 02-updates.sh: exited 0.
[cont-init.d] 03-version-requirements.sh: executing…
/var/run/s6/etc/cont-init.d/03-version-requirements.sh: line 44: 557 Illegal instruction (core dumped) semver -q “${SUPERVISOR_VERSION}” “${version}”
FATAL: You Supervisor version is: 0.81
FATAL: This add-on requires: >=0.81.0
FATAL: Please consider upgrading.

I’ve got more reports of this, seems to be an issue with Pi Zero specifically.
Looking into that.

:tada: Release v2.2.0

Full Changelog

Added

  • Adds support for SSH Agent & TCP forwarding #14
  • Added the new Hassio CLI v1.0.1

Changed

  • Prevents possible future Docker login issue
  • Pass local CircleCI Docker socket into the build container
  • Use image tagged as test as a cache resource
  • Upgrades add-on base image to v1.3.1
  • Updated maintenance year, it is 2018
  • Reduces clone depth of Oh My Zsh

Removed

  • Removes Microbadger notification hooks

I get almost the same error as @Jolanrensen
Mine says

FATAL: You Supervisor version is: 0.82
FATAL: This add-on requires: >=0.81.0
FATAL: Please consider upgrading.

It was working fine before upgrading from Hassio 0.60.1 to 0.61.1
Also running on a Pi Zero.

1 Like

:tada: Release v2.2.1

This version fixes an issue with ARMv6 based boards (Raspberry Pi 1/Zero).

Full Changelog

Changed

  • Upgrades add-on base image to v1.3.2
1 Like

Same error here. Did you solved it in any way?

I think this is a mac error - you need to remove that IP address from the known_hosts file. Try this command to remove it:

ssh-keygen -R 192.168.1.14

1 Like

:tada: Release v2.3.0

This version was focused on implementing the new and upcoming Hass.io API security layer.
It also adds zip to the default packages list and adds an option to allow remote clients to connect to forwarded ports.

Full Changelog

Fixed

  • Adds HASSIO_TOKEN to user environment

Added

  • Adds add-on icon
  • Adds zip package
  • Adds allow_remote_port_forwarding option
  • Adds documentation for allow_remote_port_forwarding option

Changed

  • Updates base image to v1.3.3
  • Updates hassio-cli to v1.2.1
  • Optimizes images in this repository
1 Like

Hi,
I have problems to upload files via ssh.

My main way to edit my configuration is to use an Testeditor via SSH. But its not possible for me to upload any files. I always see this error from Yummy FTP Pro (Mac):

With the Official SSH addon, everything works as expected.

Thats my config.

{
  "log_level": "info",
  "port": 22,
  "username": "myuser",
  "password": "xxxxx",
  "authorized_keys": [],
  "sftp": false,
  "compatibility_mode": true,
  "allow_agent_forwarding": false,
  "allow_remote_port_forwarding": true,
  "allow_tcp_forwarding": false,
  "packages": [],
  "init_commands": []
}

Thanks for helping.

Ok, I have to enable sftp…:blush:

I am perfectly able to access ssh with a key from my Mac but am failing with Termius for iPad. It says ‘handshake failed’ which probably has to do with protocols, cyphers etc. What is needed to get this to work?

Enable the compatibility mode in the addon options.

I did that and was able to login. What are the security implications of this setting?

This will enable the default suite of ciphers and key exchange algorithms.
Some of those are still secure but marked as possibly weak by several parties.

This add-on has a focus on the security side of things, so those weak ones are disabled by default.

Thanks. For now it’s working, but I think I will try some other ssh clients on iOS to see which do support the newer ciphers.

Is it possible to use more than one key value in “authorized_keys”? If so, what is the correct syntax to separate them?

[ “key1”, “key2” ]

To start with, my HA has been working fine since I did install it 3 weeks ago.
But I got problems since yesterday.
I made som changes in my automations and made a “hassio ha restart” and had to leave the computer.
Later the same day I did notice that I couldn’t connect to my hassio.local to use my HA.
I then did try to restart my HA again but got like 10-15 rows of error with github links. (yepp i should have saved that info to get more precise help but I didn’t)
I then tried to reboot the system. Worked but when the PI rebooted I can now not connect to the PI thru SSH.
ssh: connect to host hassio.local port 22: Connection refused

I am able to connect to the shares thru samba with my mac. So I can get to my config files but cause Im such a novice linux/hassio/ha user I have NOT A CLUE what to do now.

Can some one help me?