Home Assistant Community Add-on: Tor

Hmmm, that is unexpected and strange in a sense since the S6 overlay was not updated between those releases.

I’m unable to reproduce the issue as well. Could you tell me something about the system you are using? e.g. Pi3, etc…

Hi Fenck,

I’m using an RPi3. I just did a full reboot of the machine and when it came back online it was back on 0.61.0 again and Tor 1.1.0 version.

Really strange as before the reboot it mentioned the newer versions. I updated hassio again to 0.61.1 and the Tor plugin worked again. But the Tor plugin does not mention 1.1.1 is available.

Update: never mind, that was a timing issue. After using the refresh button on the addon page it is mentioning the update again. Just ran it and it came online without any issues. I suspect the 0.61.0 update to 0.61.1 failed. But I still find it strange that even though that update failed, it did report 0.61.1 in the advanced settings screen.

Authentication cookies will now be displayed in the add-on logs

Where should this be shown, exactly?
I’ve restarted the Tor add-on a couple of times, and it only seems to give me the address (blablabla.onion). The log has no lines referencing “auth” or “cookie”. I’ve tried accessing /etc/tor/torrc via SFTP, but the folder does not exist. I’m not sure if that is because of limitations of the SSH server add-on, though.

can someone help to configure the apps on android i cant start the orbot app, after setting the authentication

did you manage to solve it?i dont know how to put the cookie on orbot

I solved my issue by installing hassbian and instead of using hass.io add-ons I manually installing Tor, which worked as documented.

Regarding orbot, I just followed the instructions here

and copypasted the “HidServAuth abcdef1234567890.onion ABCDEF1122334455667789” -type of string into “Custom Torrc” in the settings.

i do get thisnumber.onion, but the rest i dont know where to get it…HidServAuth abcdef1234567890.onion(got this) ABCDEF1122334455667789(i dont know where to get this)
do i need to enable stealth i dont understand hope you can help me

It should show, but could be broken I guess?

I’m currently offline/away for a couple of weeks, moving into my new house, but I will look into it as soon as possible for me.

I have the same issue. I can see the .onion address but no cookie or authorization. 0.64.1 Installed on a raspberry pi

Manage to solved it, set a client name, and it wil give you the adress and the cookie you need👍

Yup! That is required indeed. Every client should have its own authentication cookie :slight_smile:

Glad it works!

I set a client name and it still didn’t show cookie, so I also enabled stealth. Now I see under INFO the onion and cookie as:

INFO: abcdef1234567890.onion adEG02FAsdq/GAFeNSeLvc # client: abc123

But I can’t access the site, I think maybe I’m entering the information into the torc file incorrectly. I tried in both android orbot/orfox and Windows Tor browser. In Windows the torc file has about 6 lines of code regarding data directory, geoip file, geoipv6 file, on the 7th line I entered: abcdef1234567890.onion adEG02FAsdq/GAFeNSeLvc abc123

I also tried abcdef1234567890.onion adEG02FAsdq/GAFeNSeLvc
(without client at the end)

Started the browser and tried to open my onion site but just times out. I entered the same thing into Orbot but now Orbot never starts the service. This is my first time using Tor.

you got yourself the cookie, the config is the problem in orbot , settings, torrc custom config, you have to put it like this: HidServAuth abcdef1234567890.onion adEG02FAsdq/GAFeNSeLvc, that should do it

Hmm, I did try that one in Windows Tor I forgot to mention I did that one first. I also just tried again in Orbot, it did start the service after adding it like that, but going to the onion site sill isn’t working. Not sure what I’m missing

Finally I got it! I had to add the port to the back of the onion site. I say I got it, but all that’s loaded is the top banner. it seems painfully slow.

Edit: I changed the region to United States and setup one is the bridges and it seems a bit faster, it actually loads and can be controlled anyway. Not going to win any speed contests though. Thanks for the help, I also added the :80 to ports so I don’t need the hass.io port at the end

Good, you have to put the port at the end, if you want to do it on Windows you have to locate the torr-defaults file and at the same config for orbot and a blanket space at the end, i try everything before doing it , there Is no much information.

:tada: Release v1.2.0

This release adds support for the new Hass.io API security layer.

Full Changelog


  • Adds add-on icon


  • Upgrades add-on base image to v1.3.3
  • Optimizes add-on logo
1 Like

Frustrating shit, I cannot find the cookie?

Try looking for the var/run/s6… but it’s not there. Do I need to pull the SD card and check on my PC?
All other suggestions above tried as far as I can see. No errors in the log, it gives me the .onion address.
Guess this is why Orbot won’t start…

I’m running on RPi3, fresh install (total newbie, trying to figure whether to go from SmartThings or not…)

Please share the add-on configuration, so we can point you in the right direction…

Got it working, sort of…

Set “stealth” : true and got the cookie:

“log_level”: “info”,
“socks”: false,
“hidden_services”: true,
“stealth”: true,
“client_names”: [
“ports”: [

Adding this to Orbot Torrc config, and it apparently connected, only it load the top banner, nothing else, unless it´s THAT slow…

1 Like