Home Assistant Community super slow / unusable on Firefox

Hi all,

Not sure about the category, don’t know where to post it so putting it here.

EDIT: this is not about Home Assistant but the site you are browsing right now.

I’m wondering why this site works on Chrome but on Firefox it just mostly shows a spinner whatever I try to do. Especially when posting, I had to try several times to get a post sent. I just get a spinner and a “Saving…” notification. At first I thought the server must be overburdened but then I tried on Chrome and it works perfectly.

I don’t have adblockers on, but I use strict cookie settings.

Anyone else having this problem?

Not an issue here, Firefox 104 on Win 10. Works fine.

Working fine for me too. Do you use any custom cards?

Open the browser inspection tool and check the console for errors.

You misunderstand me. I mean this forum only. Not Home Assistant itself.

image

Everything I try to do with FF looks like this.

Sure, there are errors… Can’t make much out of them

The forum software is called Discourse, they have a dedicated forum for issues, but Im guessing its the web devs themselves that would understand the issues and ask the questions. but it is worth having a search of your issues

I’m using Chrome and i’ve been experiencing issues lately too. Likewise I have 11 errors and 7 warnings in my console, for me, some are probably from ad blocking and privacy settings.

my main three issues are
(right on time for a screenshot!)


this pops up every 10-60seconds

the spinning wheels like you see

and on my mobile I cant read the forums, it hangs chrome. must be something to do with the amount of posts, anything above 30 seems to block the UI thread on the phone causing the crash

1 Like

When I had them side by side, Chrome worked fast but Firefox got stuck on every step

Am I the only one having this issue with FF?
I’m using Windows 10 and strict cookie settings if that has anything to do with it.

Being forced to use Chrome makes me login here rarely :smiley:

I’m using Standard cookie settings. Try that and see if it makes a difference.

1 Like

Seems to work fine… Of course.
Now to figure out how I can have different cookie settings for different pages.

Trying now with strict cookies and https://community.home-assistant.io added as an exception.

Edit: seems to work. Weird that this is the only site that needs this though.

I had to downgrade Firefox yesterday. The recent update breaks one of my favourite 3rd party cards.

1 Like

Nah. It still does that. Have to set standard cookie settings or it doesn’t work for long. So Chrome it is for now.

There must be some bug in the Discourse version, or some plugin on here. That doesn’t happen on other Discourse forums.

But it is only you.

1 Like

Yep. Oh well.