Home Assistant Companion for Android 1.6 and 1.7

I had the same experience as @pergola.fabio and i’m using a OnePlus 7, so maybe it’s OnePlus related, i don’t know.
But i tried the TTL / prio solution at it works for me :ok_hand: :metal:
So thank you for pointing at a possible solution :muscle:

data:
  actions:
    - action: close_garage
      title: Close Garage Door
  priority: high
  ttl: 0
message: Message to display
title: Message Title

That’s verry good to hear

still not working for me either, tested below script, maybe its the image? but what i noticed, the message didnt come, i had to wake up phone, and even i had to open the “home assistant” app , the the push message arrived

aa_test:
  alias: Doorbell notification
  sequence:
  - service: !secret notify_ha_fabio
    data:
      title: "Alert"
      message: "Someone at the door"
      data:
        # actions:
          # - action: "close_garage" # The key you are sending for the event
            # title: "Close Garage Door" # The button title 
        image: "https://i.pinimg.com/originals/0f/7b/fa/0f7bfa4e6775b5977694a6036fc85b48.png"  
        priority: high
        ttl: 0        
  

Can you test without the image to see if it works better? in all my testing today I have yet to see a delayed notification.

Yes, let’s continue the discussion and results on the GitHub thread

one feature i miss for notifications is to be able to select a sound
based on script/message i want to have another notification sound
is that already possible and not documented? to use somekind of internal sound name?

https://firebase.google.com/docs/reference/fcm/rest/v1/projects.messages#AndroidNotification

sound is not supported yet but there is an existing feature request for it via notification channels

ah cool thnx for info

Since the 1.6 release i get a huge delay for the notifications… What i was getting at the set hour now i get the notification with a 6-7 minutes delay… Is someone else having the same issue?

Is this still an issue in 1.7? Did you try to set ttl: 0 and priority: high?

Another OnePlus user here (OnePlus 6) confirming that notifications work much better when priority: high and ttl: 0 are set.

Loving the new update and just modified a bunch of my automations to include actionable notifications!

I have followed the example for the formatting of the actionable notifications, which at first seemed to be working find, but i’ve noticed that multiple actions are being triggered when clicking on the notification button, even though i’m only expecting one to run

Yes, same in 1.7. How and where to set those 2 options?
EDIT: Yes I found the two options… Now I will try them…

did you make sure to change the action keywords? I just tested this myself with 2 actions and both actions were sent separately when i selected them. both automations below did not run at the same time but only when each action was selected

service data

message: "Test"
data:
  ttl: 0
  priority: 'high'
  actions:
  - action: "action1"
    title: "button1"
  - action: "action2"
    title: "button2"

and the automations

- alias: action1
  trigger:
    platform: event
    event_type: mobile_app_notification_action
    event_data:
      action: action1
  action:
  - service: notify.mobile_app_pixel_4_xl
    data:
      message: 'action1'
      
- alias: action2
  trigger:
    platform: event
    event_type: mobile_app_notification_action
    event_data:
      action: action2
  action:
  - service: notify.mobile_app_pixel_4_xl
    data:
      message: 'action2'

My sensors for battery level and wifi name are working but I thought they would have been prefixed with the device name as set in the app. I’m planning to get my wife to install this app as well, and I don’t want ambiguity of “battery_level” vs. “battery_level_2” depending on which phone connects first.

Any entity coming from the app should be prefixed with the device name. At least the device tracker entity is named after the model of my phone, but even that should use the device name.

I submitted a fix for this exact issue that will be in 0.106 but it wont impact existing installs only new ones.

Also you can rename the entities that are created by the mobile app as they are registered entities. Once your entity is registered, changing the device name in the app will not override it. There is a feature request to set the device name during onboarding that will correct this going foward. In the meantime you can set the device name in Settings > About Phone and next time you install the app it should use that name.

Does this fix encompass not only sensors, but the device tracker and notify service as well?

This fix is only for sensor names.

The notify service call will be updated when you update the device name in App Configuration and then perform a HA restart.

For the device tracker the device name needs to be set before the entity is registered. So if you set it in Settings > About phone then next time you start fresh with the app it will pick up the name you set.

Thanks for fixing that! I guess I can manually update my entries for now.

I have family members that aren’t thrilled with being tracked all the time. Would anyone else be interested in an “only track and share home/away" option in the app? That would satisfy their desire not to be tracked all the time and allow me to finish a number of automation which I currently cannot because of their qualms.