Home Assistant Core -- TrueNAS CORE Community Plugin

For you hold outs still using this plugin…

I noticed this comment in a GitHub issue about running HA on FreeBSD.

This project doesn’t support FreeBSD, although it might work in 2022.10.x because of changes in bleak. Long term you are setting yourself up for a headache though since nothing is being tested on FreeBSD and you can expect additional breakage in the future.

Maybe there’s some life left here after all. It doesn’t change the facts though. You should still be thinking about moving HA to a supported platform, changes to bleak may only buy you a limited amount of time.

UPDATE: I just tested the Home Assistant 2022.10.0 release and default_config seems to be working again.

… at least for for now

Hey troy,

I know I need to move to a dedicated machine and I am in the process of doing that, but I really need to update my ZWaveJS2MQTT so it is compliant with the latest version of HA. I saw in another post you made that the project was renamed to ZWave JS UI and the script would need to be fixed. Would you be able to tell me how to update the existing script so it works with ZWave JS UI?

Thanks in advance for the help.

Hi @des777vg - sorry for the delay…

This is kinda dirty but should get you running again. Basically we just need to rename the upstream repository on two lines.

First open the install script for editing

iocage console $JAIL_NAME
# Press 1 to exit the menu
ee bin/install_zj2m

Now on lines 13 and 18 we need to change zwavejs2mqtt to zwave-js-ui

# Line 13 - BEFORE
  local release="https://api.github.com/repos/zwave-js/zwavejs2mqtt/releases/latest"
# Line 13 - AFTER
  local release="https://api.github.com/repos/zwave-js/zwave-js-ui/releases/latest"
# Line 18 - BEFORE
  cd "${workdir}"/*zwavejs2mqtt* || goodbye 1 "failed to get release" ; echo " OK"
# Line 18 - AFTER
  cd "${workdir}"/*zwave-js-ui* || goodbye 1 "failed to get release" ; echo " OK"

To save and exit, press ESC then press ENTER twice

Now you should be able to start the menu again by typing menu and press enter.
Use the menu to option 4 to upgrade and finally option 5 to start zwave-js-ui.

My TrueNAS CORE 13 VM is broke down ATM so I can’t test this ahead of time – Please let me know your success or not. Good Luck!

Thanks for the help as always the fix worked and z-wave now works in home assistant. One issue though is my siren alarm (NAS-AB01Z) no longer outputs a sound when I turn it on via the configuration panel in HA and the plugin. All the information is reporting correctly and there are no errors on either side.

Glad it’s mostly working again. Sorry I can’t offer much help with your siren. My only guess is to try refreshing values and/or re-interviewing the device from the zwave-js-ui.

I think that in one of the recent versions of the zwave js there was an announced breaking change that has made some of the devices (partially) not working. Usually re-interviewing, in worst case removing and pairing back the device was required. I’ve had one such case with valve thermostat. After re-adding everything works ok again.
Here is the change log:

1 Like

Re-interviewing node solved the issue thanks again for the quick response and thanks @adorobis for the follow up post.

1 Like

I have migrated my HA from TN Core in jail/iocage to HA in app TN Scale.
Every thing works fine bu I still have the HASS Configurator installed and it don’t works any more.
Could you explain how to remove the HASS Configurator or how to modify it to work in TN Scale HA app?

So you transferred your Home Assistant configuration to TN Scale and HASS Configurator still shows up in the side panel of Home Assistant, is this correct?

If so, that’s just an iframe that was enabled in homeassistant/packages/freenas_plugin.yaml or in a directory named homeassistant/packages/truenas_plugin, depending on when you initially installed the plugin. Just remove whichever you have and restart Home Assistant to get rid of it.

I’m sorry, I don’t use any TN Scale apps so I’m unable to help in that regard.

Thank you for the instructions

1 Like

Thank you for all of your contributions.
I recently bit the bullet & bought a used micro PC with an i5, 8G of RAM and installed a SSD with HA OS.

I used your plugins on FreeNAS/TrueNAS for a couple of years and it worked a treat. The death of ESPHome ws the death knell I couldn’t ignore.

You made many people very happy.

1 Like

I think the key was your prompt support for whatever the issue could have been. Many thanks for that! Have been using it for over 2 years.
On the other hand I must admit that since switching to Docker installation on Debian the support required is close to zero. I can focus on integrating new devices, making new automations etc rather than keeping HA up and running.

1 Like

I couldn’t agree more :grinning_face_with_smiling_eyes:

And I think we got out just in time. I have a feeling the days are numbered for plugins in general, on TrueNAS CORE. I think when it comes to running any apps on TrueNAS, there will be a push to use TrueNAS SCALE.

Speaking of TrueNAS SCALE - I’m running 22.12-RC.1 (Bluefin release) and finally USB passthrough has been added to the VMs. I was gonna install Debian but decided to give Home Assistant OS another try instead. Happy to report, the USB Z-WAVE radio works great.

1 Like

Hope they won’t remove jails though. Since I moved most of the Home Assistant apps to Docker I’m left mostly with MariaDB, Plex and Nextcloud. And those are probably too heavy for my low power mini PC. But I’m good just running them in jails, no need for a plugin. I don’t have any pressure to switch to SCALE at the moment.

Jails are safe… Only plugins are doomed

1 Like

Over the weekend I’ll be submitting a PR to ix-systems having my remaining plugins removed from TrueNAS CORE. The list includes the following plugins

  • Gogs
  • TasmoAdmin
  • Node-Red
  • Mosquitto MQTT Broker

It’s done

I’ll continue trying to support anyone using my plugins for the next few months. Also, any of these plugins can continue to be used and updated as if they were a regular jail.

1 Like

Hopefully, most users have moved on to a supported installation method by now

If you’re still holding on here, Home Assistant will soon be dropping support for Python 3.9. I’ve added a wiki page to help you update. Good Luck!

For those considering a switch to TrueNAS SCALE. I ended up making a little installation guide for HAOS

1 Like

I’d like to thank @troy for his inspiring generosity in helping so many of us run Home Assistant on Truenas over the past few years. People like him really make the internet go around.

I held on for a couple of months without any updates, whilst trying to find a solution. I had to give up on keeping it all in the Truenas box, as I specifically need USB ports to be accessed direct by HA as I’m using a Zigbee controller, so the other methods weren’t an option.

In the end I had to bite the bullet and use a dedicated piece of hardware. Thought about a Pi, some suggested a NUC. Then I realised I had a very old Lenovo laptop laying in a cupboard, dating back to 2011. I was slightly surprised to find it had the required UEFI boot mode ([probably among the oldest pieces of kit to have this feature) and it worked perfectly.

What made the transition painless was HA’s backup feature. Not only was it easy to backup my old configuration from my Truenas jail installation of HA to the new version, but it also allowed easy migration of my Zigbee controller. Overall very painless and I recommend if anyone hasn’t made the jump away from Truenas, any crappy old bit of hardware you have laying around can probably work just fine as a HA instance without too much difficulty.


FWIW - The latest version of TrueNAS SCALE has an easy way to passthrough USB to a VM - It’s one of the reasons I decided to give HAOS another try.

1 Like

I thought about SCALE but heard samba performance isn’t as good as CORE and I move a lot of files on and off my Truenas, plus as I understand it everything needs to be set up again. It’s a good option for some though, if they want to keep everything in the Truenas box.