Home Assistant Core Update 2024.3.1 failure

First time in 2 years, so a bit puzzled what to do now… I installed HAOS update this morning to 12.1, then Core update 2024.3.1 notification came up right after restart and this one does not move any longer…

I receive a message at the bottom corner that says this:


Failed to call service update/install. Error updating Home Assistant Core.

Has anyone seen similar behavior with these versions of setup? Should I just skip it and wait for another update before re-attempting?

Current CORE: 2024.3.0
HAOS: 12.1
supervisor: 2024.03.0
frontend: 20240306.0

Most likely HA did not complete restart when you tried to update it. Reboot HA and try again.

that was the first thing I did… no luck.

edit: fast forward 3 hours, a new message popped up: you’re low on storage…, so after removing 60+ old backups, it allowed me to install the newest version without any issues. Case closed.


Run into the same issue with HA supervised on Debian.
+400GB free disc, so that is not the issue.
After run apt upgrades and reboot the OS i was able to install.

I have the same issue, rebooting did not help. Running on rpi4, VERY basic install with very few integrations/addons. Never had an issue before. Definitely not DNS/Internet related as i’ve tried different networks/dns servers. Only 21% disk space used (500gb nvme), most of which is my tiny Plex library.

These are the errors/log entries. Anyone got any clue?

thx in advance.

I was having the same problem, turned out to be an issue with the networking.

I had recently swapped the home assistant to a static IP and somehow this killed all of the outbound(but not inbound) networking. I confirmed this by opening an SSH web shell and pinging Google/etc(which failed).

Once I swapped back to DHCP the update worked fine, probably an issue with the IP I had assigned.