Home Assistant crashes every Monday around 1:30AM. Troubleshoot help requested

For the last few weeks my home assistant crashes every Monday morning around 1:30AM. Automations seem to stop working, Samba and SSH access are down. The front-end is still available most of the times (not always), but the history is not working anymore. The supervisor tab also shows a blank screen. Trying to shutdown or reboot via server configuration doesn’t do anything. The only way to get things up and running again is by power-cycling the Rpi. Sometimes more than one power cycle is needed. After a successful reboot I see that the last history recordings have happened around 1:30AM. After reboot I cannot check the logs anymore what caused the crash. Before reboot I cannot see the supervisor or host logs since they are on the blank supervisor page. Before reboot I can see the core log, but so far I do not see the cause there. All I see is recorder errors, because the database is down. What would be the best way to find the root-cause? I tried disabling certain automations, configurations and integrations on Sunday evening and see if it crashes overnight. No luck so far and I feel that this trail and error route might take ages with only one trail a week. Is there a way to read back the logs before they are erased? (power-off hte Rpi after the crash, take out the SD-card, read the logs on my windows PC, before restarting the Rpi?) I read a lot off issues can occur due to corrupted SD cards. How can I check if the SD is OK or not? Any other Ideas on how to find the root-cause on these crashes?
Running Home Assistant OS on Rpi 3B+, regular updates of core and OS are done. Always running the latest or previous version. None of the updates so far solved the issue.

1 Like

Hi, check out this thread, seems like exactly the same issue I’m having, I’m also running Home Assistant on a Raspberry Pi 4, this happens every Monday morning about the time you state, I’m thinking it occurs due to something happening based on start of week, I have garbage collection custom component as did the person who created the other post, do you use this too?

Thanks @captain_daveman for pointing me to that other thread. I did search for similar issues before opening this tread, but I apparently overlooked that one. To keep things in one place I’ll post in that tread from now on.

I have the same problem

@captain_daveman, @Plevuus, @nelsonamen