Home Assistant custom local addon turns off with HAOS updates

I am running an HAOS in Raspberry pi 4 (4GB) with latest os version of 12.2 and core: 2024.5.2.

I tried searching for this same issue with no luck.

I have created an custom add-on (with this as a base Tutorial: Making your first add-on | Home Assistant Developer Docs) to local directory that has simple python script loop that checks time and turns off & on switches that are connected to HA.
The script works well and doesn’t have any issues but if I run updates to HA or the system reboots, then my custom add-on turns off. I have enabled the “start on boot” option but this doesn’t make a difference.

Other add-ons do start with reboots or updates. What should I consider to make HA start my add-on on reboots/updates?

Thank you. I hope I created my first topic in correct place.

Have you checked in the logs that it is not failing to start because it is trying to connect to HA before it has started?

I checked the system logs. It doesn’t show anything peculiar. My addon is dead simple so it only prints the terminal outputs to addon logs. There are no issues.

I will look into HA logs again.

Edit: There was a OS update released and I monitored the update and restart. In this instance the supervisor did start the add-on correctly. So the reason might be something else. I will monitor the behavior of the add-on if it turns off again.