Home Assistant + Docker + Tellstick Duo = headache


#1

Hi,

I really need some help here.
Im not able to get my Home Assistant (installed in docker) to pick up my Tellstick Duo that are connected to my RPI3 via USB.
I do get my Tellstick to work outside docker, i am able to send commands to switch on/off devices.
But then i run my Docker Container and go to my webgui for HA (not hass.io) i can see that HA have not detected my Tellstick.

How do i make my docker to use my RPIś USB? And how do i configure it the right way in configuration.yaml?
At the moment i have tried this in my configfile:
tellstick:
usb_path: /dev/attyAMA0

At the docker side i have tried stuff like:
docker run -t -i --privileged -v /dev/bus/usb:/dev/bus/usb
–privileged -v --device /dev/ttyAMA0
But nothing is working.

Setup:
RPI3 with Rasbian
Docker version 18.03.1-ce
Home Assistant version 0.73.2
Tellstick Duo

I hope someone can help me.

BR
Ekesa


#2

are you sure that the device is located at /dev/ttyAMA0?

If you’re sure that it’s located there (sometimes the USB devices get new addresses on a reboot) then try using “–device /dev/ttyAMA0:/dev/ttyAMA0” in your docker run command.