Home assistant doesn't open on raspberry suddenly

Hi I have installed home assistant on raspberry and suddenly when I try to open the Url from remote or locally I’m getting this error :


I tried to update from command prompt on rasbian but said that python 6 needed but can’t find it to download

That is odd, given that python is up to 3.7. You sure that it doesn’t say 3.6?

Please see the sticky post on how to help us help you. It broke is not enough.

I’m guessing you’ve probably done one of the manual venv install methods, but guessing isn’t enough to help you here.

I have this error when im trying to update:
homeassistant requires Python ‘>=3.6.0’ but the running Python is 3.5.3
what command should i use to update >=3.6.0 please?

Thats why im posting for help because i dont have find anything similar with my problem…

Please please read the link @Tinkerer gave you.

1 Like

I tried everything but still cant access to my home assistant, im scare that the only way to restore my home assistant is to format the raspberry,
I tried this methods to update the python but still say that i have old python version:
You just won the lottery. How do you build the most stable HA server? ,
https://www.home-assistant.io/docs/installation/virtualenv

Is that a hint that you used some form of venv install on the Raspberry Pi?

Is it really that hard to read the sticky post and provide us with the information listed in step 10?

Sry for misunderstood,
Im using:

  • Homeassistant Version: 0.96.4
  • I installed on Raspberry PI 3+ with Raspbian OS in virtual environment

And now im trying restore my homeassistant using update but i get the error that i wrote

This is conflicting information.

Did you use PYTHON VIRTUAL ENVIRONMENT or HASSIO IN DOCKER?

If you want help you need to provide better information

PYTHON VIRTUAL ENVIRONMENT

Then it’s time to upgrade to Raspbian Buster and rebuild your venv.

I make a clean installation of raspbian buster with desktop,I followed the the Alternative installation procedure of hassio on generic linux host and everything works perfectly but when i put the old files on my configuration files stopped works again.
The installed version was the latest 0.97.2

The home assistant log:

2019-08-17 11:22:08 INFO (MainThread) [homeassistant.setup] Setup of domain logger took 0.0 seconds.
2019-08-17 11:22:08 INFO (MainThread) [homeassistant.setup] Setting up http
2019-08-17 11:22:08 INFO (MainThread) [homeassistant.setup] Setup of domain http took 0.0 seconds.
2019-08-17 11:22:08 INFO (MainThread) [homeassistant.setup] Setting up system_log
2019-08-17 11:22:08 INFO (MainThread) [homeassistant.setup] Setup of domain system_log took 0.0 seconds.
2019-08-17 11:22:08 INFO (MainThread) [homeassistant.setup] Setting up recorder
2019-08-17 11:22:10 WARNING (Recorder) [homeassistant.components.recorder] Ended unfinished session (id=127 from 2019-08-14 11:48:32.848558)
2019-08-17 11:22:10 INFO (MainThread) [homeassistant.setup] Setup of domain recorder took 2.1 seconds.

Not sure then why you didn’t just flash Hassbian, but …

Run a configuration check. Share the results.

I dont want hassbian because i want the raspberry pi also for unifi controller,vpn server,etc
No i tried to run from ssh and locally the followed command with sudo -i right’s :


[email protected]:~# docker exec home-assistant python -m homeassistant --script check_config --config /config

but i get this error:

Error: No such container: home-assistant

Hassbian is Raspbian + Home Assistant, but …

That command is for Docker, you’ve got a venv install. Maybe you should swing over to the Discord server and get more interactive help.

I’m confused, after format i followed that procedure to install hass.io

1.	sudo -i
2.	apt-get install software-properties-common
3.	add-apt-repository universe
4.	apt-get update
5.	apt-get install -y apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat
6.	curl -fsSL get.docker.com | sh
7.	curl -sL https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh | bash -s -- -m raspberrypi3

Everything works good until i tried to paste the old data on my homeassistant directory,i already sent on discord to find a solution, thanks for help!

I found a solution,
I make a clear unninstallation with that procedure:

sudo systemctl stop hassio-supervisor.service
sudo systemctl disable hassio-supervisor.service
sudo systemctl disable hassio-apparmor.service
sudo systemctl daemon-reload
sudo su
cd /etc/systemd/system
rm hassio-*

i deleted the homeassistant folder and i make a fresh installation home assistant(not rasspbian)
Then i discover that one of custom component cause the problem after restart, so i deleted and everything ok