Home Assistant doesn't show up on network on first boot

I’ve been using Home Assistant for several years but I’m lost here and would appreciate any help.

A few months ago my home assistant installation suddenly failed after working flawlessly for many years. I’ve done a post here about it (though it seems to have been used as an umbrella post for several other problems from other users): HA stops working. Supervisor: Disconnected

I haven’t had the time to troubleshoot and I decided it was best to just install a new instance of home assistance and recover with the latest backup. So I installed a new sd card following the official documentation here:

The problem is that when booting up for the first time the new installation doesn’t even show up on the network.

  • I’ve tried different ethernet cables
  • I’ve tried a different (new) power supply
  • I’ve tried a different (new) Raspberry Pi 3B+
  • I’ve tried a different (new) sd card (sandisk extreme 64gb)
  • I’ve tried changing ethernet ports on the switch it is connected to (it’s always been connected to that switch, and other devices connected are working fine).

And the result is always the same - the device doesn’t even show up on the network (logging in to the Asus router I use).

The only other thing I can think of is that home assistant is not using DHCP by default (my network is configured on the 172.xx.x.xxx subnet and the rpi is configured with a static address in the router), but I find it unbelievable that was the case. Has there been any recent change to the OS in that it comes shipped with a default static ip address?

I’ve run out of ideas. I was sure it was the sd card that failed after many years working flawlessly, but the problem is apparently somewhere else.

Any help would be greatly appreciated.

Thank you in advance.

172 is the same IP range docker uses. I can see potential issues using this range as your network range.

I’m not saying this is the cause of the problem, but it could be a potential cause of the problem.

thank you for the prompt reply.

My network is in the range 172.2x.0.0/24

It was working fine on that range for several years. And it will be a pain to change the entire network to use the 192.168 range again (dozens of devices connected and a couple of proxmox servers with several VM’s).

I also don’t use docker at all in any of my servers. HA has used a dedicated rpi since the very beginning. Do you really think that could be the culprit? I would hate to lose a few days re-configuring the network to find out it was something else entirely.

HA uses docker. Addons are docker containers, so is the supervisor and HA itself. It could cause conflicts. I don’t think it will seeing that youre using 172.2x and HA is using 172.17.0.x. But I’m not a networking guru, I fumble around and use google a lot.

Outside that, I’d try to remove your dhcp reservations to see if HA appears without it.

There is nothing to worry about. - is the network address range for /16 subnet. Therefore if you have no hosts in the address range of 172.17.x.x you have nothing to worry about.


I’ve deleted the static ip address of Home Assistant in the router and I’ve reboot it - et voila, Home Assistant shows up on the network. Not sure if it only needed a reboot of the router - I’ve since assigned a static ip again and it still shows up after another reboot.

Bad news is that it’s not allowing me to recover the latest full backup - it gives me a “400 Bad Request” when i try to upload the backup. All other backups seem to be partial backups of mariadb or home assistant core (or far too old). Time to start again, I guess.

I feel a bit dumb about not having done a reboot of the router previously to starting this thread (never thought it would need it!) but maybe it ends up being helpful to someone else down the line. For reference, my router is an Asus RT-AX86U running the latest Asuswrt-Merlin firmware (3004.388.6).

Thank you @petro and @os.habitats.tech for your prompt help.