Home Assistant ESPHome missing one entities

I have an issue that I have been unable to track down so far. I have a ESPhome device that I’m using for monitoring my dog house. I have a few sensors and relays to control including two Dallas temperature sensors. Everything seems to work fine if I look at the ESPHOME logs except that the second Dallas sensor does not show up as an entity in home assistant. Everything else is just fine.

My Code

  sda: 21
  scl: 22
  scan: true
  id: bus_a
  - pin: 19

# Individual sensors
  - platform: dallas
    address: 0x3c67e1379ec7ff28
    name: "Doghouse Outside Temperature"
  - platform: dallas
    address: 0x5950a137fc8dff28
    name: "Doghouse Inside Temperature"
  - platform: bmp085
      name: "Doghouse CTRL Temperature"
      name: "Doghouse CTRL Pressure"
    update_interval: 60s

And your esphome log?

Example Log

[13:26:44][D][dallas.sensor:143]: ‘Doghouse Outside Temperature’: Got Temperature=16.6°C
[13:26:44][D][sensor:127]: ‘Doghouse Outside Temperature’: Sending state 16.56250 °C with 1 decimals of accuracy
[13:26:44][D][dallas.sensor:143]: ‘Doghouse Inside Temperature’: Got Temperature=16.9°C
[13:26:44][D][sensor:127]: ‘Doghouse Inside Temperature’: Sending state 16.87500 °C with 1 decimals of accuracy
[13:27:00][D][bmp085.sensor:079]: Got Temperature=15.6 °C
[13:27:00][D][sensor:127]: ‘Doghouse CTRL Temperature’: Sending state 15.62290 °C with 1 decimals of accuracy
[13:27:00][D][bmp085.sensor:125]: Got Pressure=876.1 hPa
[13:27:01][D][sensor:127]: ‘Doghouse CTRL Pressure’: Sending state 876.14551 hPa with 1 decimals of accuracy

Did you try to remove and re-add this esphome? Or, do you, by any chance have two devices registered on the same esphome name or IP? It can happen when you test and tinker with device…

Tried to remove and add it back in with exactly the same result. Pretty sure there is no IP conflict

when you look at the device in HA, what do you see as entities?

I only see 6 of the 7 entities. I’ve tried refreshing, rebooting even remove the instant and reinstalling but nothing seems to work. The ESP Board seems to be reading it just fine but for some reason home assistant does not see it.

Which one is missing?

Edit: sorry, you said the second dallas one, I assume the inside temp one.

You haven’t hidden one by mistake?

Try to set up another sensor based upon a template of the raw value of the missing entity. That should show under integrations.

Well it seems like I fixed it but not sure why. I tried a new sensor and this worked just fine. I now have both inside and outside temperatures working. I just find it odd that the sensor appeared to be read fine in the logs.

Thanks for all the comments and ideas

1 Like