Home Assistant Fails to Start after Debian update

I had to walk away from some stuff for a while… long story short nothing has been udpated in months. I started updating server and debian on my pi where HASSIO runs… but now I cannot get home assistant to start.

systemctl status hassio-supervisor.service
● hassio-supervisor.service - Hass.io supervisor
     Loaded: loaded (/etc/systemd/system/hassio-supervisor.service; enabled; vendor preset: enabled)
     Active: active (running) since Wed 2022-11-23 17:28:37 EST; 16min ago
    Process: 1148 ExecStartPre=/usr/bin/docker stop hassio_supervisor (code=exited, status=0/SUCCESS)
   Main PID: 1246 (bash)
      Tasks: 11 (limit: 8985)
        CPU: 812ms
     CGroup: /system.slice/hassio-supervisor.service
             ├─1246 bash /usr/sbin/hassio-supervisor
             ├─1349 bash /usr/sbin/hassio-supervisor
             └─1350 docker start --attach hassio_supervisor
hass hassio-supervisor[1350]: 22-11-23 17:42:53 INFO (MainThread) [supervisor.auth] Home Assistant not running, checking cache"

I get this error, hassio supervisor seems to be running and connected to my MQTT server…

Any ideas?

To note:
I tried ha core start and got the following

Nov 23 17:57:45 hass hassio-supervisor[1350]: 22-11-23 17:57:45 ERROR (MainThread) [supervisor.utils] Can't execute start while a task is in progress

There were recent changes that required some additional services / sockets. Let me find the thread and I’ll post the link here in a few minutes.

Try some other stuff like

ha core info
ha supervisor info

Thanks @FredTheFrog that seems to have fixed it

1 Like