Home Assistant Green Brand New not working

Hi all

Very new to this. Ordered my home assistant green. Followed the instruction, getting error message “Error Installing Home Assistant”.

NSURLErrorDomain -1004

Can someone please help on what to do next? I have the error log but can’t post with so many links. Thanks Manish

Welcome! How are you attempting to access HA Green (Windows Pc, Phone etc…)? That error is a network error.

Using iPhone App

you don’t have “Limit IP Address Tracking” turned on for your iphone do you?
settings->wifi-> choose your home wifi->scroll till you see it.

Try reaching Home Assistant in a browser using the ip address of your Green with :8123 at the end. So something like

You should be able to find what IP address it has been assigned from your router.

To expand on @cogneato suggestion, you can open CMD and ping homeassistant.local -4

You’ll get an IP and results if it’s replying to the ping.

or enter http://homeassistant.local:8123/ in your browser to connect.

Tried turning that off. No success. Any other guesses I can try? I was really looking forward to use home assistant?

Tried accessing it from local browser. No luck. Who can I contact to help me with this. I just spent $150+ buying this and it’s not working first step. Very disappointed.

1 Like

OK, so to start with - we need to know how it’s connected to your network. Is it a normal network, or do you have a VLan setup? Have you verified in the router that it has actually given the Home Assistant Green an IP address?

Hi Andrew
Yes I have logged into the router and have a confirmed ip address of I have tried putting this manually in iOS app and it shows me the error code

Could not connect to the server.

Error Code:
NSURLErrorDomain -1004

As a Google search shows, NSURLError’s are caused by SSL issues. When you put the IP address into the app - you should have put:

Out of the box Home Assistant does NOT use https

This can occur when a host name resolves, but the host is down or may not be accepting connections on a certain port.
NSURLErrorCannotConnectToHost | Apple Developer Documentation

Don’t use the app. Continue trying to reach HA in a browser from a device which is on the same network. What exactly are you entering in the address bar of your browser?

Where were you seeing the error about installing Home Assistant?

Do you have a screenshot of your browser attempt that includes the address you are using?

If you need, you can factory reset it using an SD card and the process described in the documentation: Resetting the device – Home Assistant Green

This process requires that the Green has access to the internet to download the parts needed to complete setup.