Home Assistant in Mac M1


Has anybody made HA work in a Mac M1? I have tried installing the docker image, but it is Core, i want to have the full HA version. I have also tried with VMWare fusion, but the image is not recognised as a valid one


I have done some months ago, on an early version of Parallels. I had to work hard to get Debian installed back then, but it should be easier now. I can’t remember what I had to do to get HA installed, but I did a full supervisd install, but very little in the way of addons. The vm is switched off at the moment, otherwise I’d take a look at the architectures of the vms. I think they were qemu.

I plan to give it another go in a couple of weeks, to see if I can migrate off my 7/8 year on Mac mini. I have Plex running straight on M1, and an Ubuntu VM running Docker with Portainer, Hoobs and InfluxDB.

I think the challenge may be getting all the ARM64 containers for the various addons I use. But I’ll figure that out as I stand it up, and then try to migrate over.

Yep in parallels it works, but on the OSX directly it doesnt. The .vdi disk is not recognised as a valid one in vmware fusion, i assume it is because it is creating an arm image instead of a x86

Looks like Fusion is pretty new to M1, so you mileage may vary. Are you trying to install as a Fusion. VM or direct on to OS X? What vdi are you using?


also the ova directly and no luck with either.

I am installing this as a disk in fusion. In an old mac (x86) it works fine with virtualbox, but there is no virtualbox for mac, thats why i need to use fusion (maybe its not even a valid vdi for fusion as it is vmware…)

Looking at their GitHub, looks like they support x86 for HassOS on vm. I’m not sure it will install directly, so you may need to install Debian (you can use Ubuntu, but it will say unsupported), and then install Supervisd, possibly with qemu as the architecture. Just means you need to maintain the so, which is no major hassle.

Yeah but my arch is arm, not x86, that’s the problem
The other option is to install the supervisor without installing the whole os, which I don’t know if is even possible using docker, for example. There’s an image, but for core only. Is there any docker image for the supervisor (or even better, for core+supervisor together)?

You’d need to install you own os in a vm, I would recommend Debian. If you do this on parallels, it will offer to download Debian for you, but that maybe a client version whilst you’d be better with server. Then you run the supersvised install script. Details are in the supervised installation section on the page below. It will install supervisor and core, just like in hassos, except you need to do your own os maintenance (run regular updates/upgrades). If you are familiar with Linux those updates won’t be a problem, if you aren’t then you probably want to be trying to install on something other than an M1 Mac at the moment.

1 Like

The differences in what you get are shown here - Installation - Home Assistant

wow, so, creating a vm with linux and installing HA there? I thought about that but i was expecting that this could be installed directly in OSX directly.

Is there any reason for not having a full HA docker image? Thats way easier

Because ha uses Docker for all it’s element. When you install hassos, it is just a custom os with Docker, in which it runs core (home assistant container), supervisor container, observer container, etc, etc.

So your can’t run all of HA in one docker container, because your’d be running docker inside docker.

For MacOS you have two choices, run core in a container on docker, or run a vm (which I guess is HassOS - I haven’t looked), inside that VM it will be running docker. So if the vm HA supply doesn’t work, which you say it doesn’t, you have to roll your own.

you can run docker in docker :slight_smile:

I will stick to the vm solution but maybe somebody should release a VM version of HA compatible with ARM64 or even to be able to install supervisor as a OSX package in the same way it is installed in debian

Ahh, I see you can.

I don’t see the HA team developing an ARM64 version quick, their focus is Debian. Now if RaspberryPi went to ARM64, then it might happen. Even though I think it runs a 64bit os in arm, so I don’t really know the difference - well I do, but don’t know how different the arm chips are.

I imagine you can try to use the Linux install script, which will I’m sure try to install supervisor into you docker instance, but I’d expect a boat load of mess, and I try to keep my base os clean. Much easier to wipe and rebuild a vm, or snapshot and try things. If MacOS goes wrong, then it has all gone. Had to rebuild a month or so ago, to recover 300GB it had consumed somewhere - rebuild was under advice or senior Apple resource…

Thanks! It was an useful conversation :wink:

New to HomeAssistant and only know enough to be dangerous. I have tried using UTM which creates virtual X86. Seem so install ok but QEMU guest doesn’t start. Home assistant start with ha prompt but no IP displayed to access and 8123 doesn’t work either

Not sure what UTM is? I plan to give it another go over the coming weeks, so will give some details here.

Had a look at what UTM is and see it uses QEMU under the hood. I would assume you should be able to emulate an AMD64 or an ARM7 machine, install Debian and then just run the supervisor install script. I might give it a go…

I’ve just gone through and installed HA Supervised on Debian on Parallels on Mac M1 Mini. The basics of this are:

Waited a little while and Home Assistant was available on port 8123 at the servers IP (which can be found using ‘ip addr’ or look up on your router). This is the set of containers created. I see the homeassistant container is qemuarm-64 whilst all others are aarch64, which all looks fine.

I’ve not tested it any further than that apart from to add SSH/Terminal and File Editor, but it seems to run natively on Debian.

I’m hoping I can migrate my whole environment across to the M1, it has gone a lot better than I had hoped.


@RogTP thank you for writing up this step by step summary! If you do not mind sharing any other tips/tricks or shortcomings that you find, I would appreciate it! I plan to do this migration to M1 in about a month.

I need to have a day or so clear to try a shift, last time I moved there were some hiccups along the way. However this time I don’t have any non HA containers on the VM, so hopefully it should be good.

I’ve installed all the addons onto the server to make sure they are all available as aarch64, I’ll do a trial startup of each of them prior to missing. I know I have a very big apache addon using stuff from the share folder which was a pain, but I may dump that anyway.

Any questions about getting basic setup going, just give me a shout.