Home Assistant Instance became Inaccessible by using DuckDNS

I installed home assistant on virtual box, and I had been setting up plugins and services.
I was playing around with home assistant on local server.
Then for a simple task I installed Home Assistant android app to access HA remotely.
I added DuckDNS plugin and upgraded configuration with a new duckdns domain.
I couldn’t access my router configuration due to some access prohibitions. So I skipped that step, assuming it might work without that (I tried every way to access router configuration and after getting frustrated, I thought of trying by skipping that step. Now I realize that was a dumb move).

So, after I upgraded my configuration and restarted home assistant, I became unable to access home assistant instance through duckdns domain and also by ‘http://homeassistant.local:8123/’ which I was using before.

As I am still unable to change router configuration. Is there anyway to re access my home assistant instance so that I can at least work on localhost.
And is there anyway possible to access homeassistant instance remotely without having access to router configuration?
Thanks. Any kind of help would be much appreciated.

Doesn’t the DuckDNS integration also add certificates via Let’s Encrypt?

If so, have you tried https://homeassistant.local:8123? (note that I changed http to httpS)

1 Like

Nabu Casa.

1 Like

Thanks for your response.
I was able to access it now using ‘https’ on local host. :sweat_smile:
But I wonder previously I was not using ‘https’ what exactly makes this change specifically for local host? :thinking:

And yes I used let’s encrypt with the DuckDNS. The reason that ha instance is not accessible through duckdns domain I think is that: I didn’t do port forwarding in the router, so it simply doesn’t direct me to local instance when I try to access it remotely. Is this the reason?

Hi Tom. Thanks for your response.
I will look into this option.
Do you have any recommended resource to get information about this plugin/service?

1 Like

As I mentioned, you were using HTTP (without a certificate or encrypted communications) on your default HA installation.
When you installed the DuckDNS addon, you also created TLS certificates for HTTPS.

Your HA automatically changed it’s access from non-encrypted HTTP to encrypted HTTPS, requiring https

1 Like

I see, I didn’t know that it will be effective on localhost as well.
Thanks for clarification.

Just a note as I think this is important for you to understand.

localhost just points to which is the loopback address to speak to the same host.
The webserver is built into HA for you, so it doesn’t matter if you reach:

https://127.0.01:8123 or
https://localhost:8123 or
https://homeassistant.local:8123/ or
https://xxx.xxx.xxx.xxx:8123 (your computers LAN IP on the network)

All of these will be using TLS with your brand new certificate, as that is controlled by HA!

Thanks. That was new information for me. But right now, just the third option is working for me.
By the way, As I had not been able to access my router configuration, so I came across another alternate of port forwarding, that is, ‘ssh-tunneling’.
Do you have information whether this method can be used to access HA instance remotely or not? :thinking:

Depends on your objectives.

If you are trying to connect from your phone while out and about, that seems cumbersome.
Even with SSH Tunneling, you won’t technically be able to access to your network without another host outside your network involved.