Home Assistant interface for Garmin's Connect IQ platform

Yes, in my case the host url responds properly when I’m accessing it using my phone.

It’s in the form of

Should it look like that, or…

Thanks for your reply. Yes Hass is working fine via the URL on my phone. I am using http and not https.

I’m unsure what is going on here, but in an effort to debug it, could either of you try not specifying a Long Lived Access Token, and see if it prompts you to log in on your phone?

If I remove LLAT then I get the following error in the Connect App when I open the HassIQ widget on the watch:

Webpage not available

The webpage at could not be loaded because:


It looks as if standard http ciq requests aren’t supported by the Garmin Android app.

You would need to move to https for your Hass install.

I have tried to use https://<ip> with a self signed certificate but that did not solve the “status: -300” error.
I solved the issue by:

  1. Enabling DuckDNS add-on in hass.io
  2. Adding a static host entry on my router (USG) which is pointing <mydomain>.duckdns.org to the local IP of the HA server - as I don’t want to expose HA on the internet.

I used the info from the site below to setup the static host entry on the USG https://gist.github.com/troyfontaine/a0a0098d6a8c333e5316ebf16db1c425 and the Android app About HA Client - native Android client for Home Assistant to test the connection. When I got the connection working with the “HA Client” it also worked with hassiq.


Thanks for the information!

I’m just started to test the widget. I get status ‘0’ , then ‘2’. Meantime the Garmin connect app stops on my phone.
I use DuckDNS add-on in hass.io so https is ok.
Garmin Connect version 4.21
Forerunner 645

Have you got a group setup with the same name set in the app as HA?

Yes. I’m new to HA, but I succesfully made two groups in configuration.yaml. On the web ui I can see my groups on different tabs. One of them is named in the group setup.

If you are using the default setup and layout your group should be in the groups.yaml file and look a bit like this:


Thanks, it works now. (I scrambled the group definition somehow.)

can the new Fenix 6 line be added to the list of supported devices, please?

1 Like

@alanf When trying to set up through the settings in ConnectIQ, I am unable to change the url within the settings, if i change the field at all I get the error message “Only letters and numbers allowed”. Is there a workaround for this? In fact, this error even applies to the group settings, it wont allow “.” at all.

+1 yes please!

I’m trying to sort this out it’s seem to be not working!

These are my setting and I’m using cloud instead of duckdns


Thanks for updating the Garmin app for Fenix 6. Works great!


I just installed hassiq on my garmin vivoactive 3 music.
After setting up everything, the connect app prompted me to sign in, but it only loaded a blank page without me being able to complete the sign in process.
Using the long live access token method, I got an error code 1001.

I went through the thread, I did not see any report that is similar to mine. Anything else that I can try?

Hey there! I don’ t know how I screwed setting this up, once I got it running WoW!!

I got it to work with Nabu Casa and a long lived token!!

@kbtang88, did you get this working? If not try deleting the garmin: line in your file, you don’t need the domain, its just a group.