Home Assistant interface for Garmin's Connect IQ platform

I’m just started to test the widget. I get status ‘0’ , then ‘2’. Meantime the Garmin connect app stops on my phone.
I use DuckDNS add-on in hass.io so https is ok.
Garmin Connect version 4.21
Forerunner 645

Have you got a group setup with the same name set in the app as HA?

Yes. I’m new to HA, but I succesfully made two groups in configuration.yaml. On the web ui I can see my groups on different tabs. One of them is named in the group setup.

If you are using the default setup and layout your group should be in the groups.yaml file and look a bit like this:


Thanks, it works now. (I scrambled the group definition somehow.)

can the new Fenix 6 line be added to the list of supported devices, please?

1 Like

@alanf When trying to set up through the settings in ConnectIQ, I am unable to change the url within the settings, if i change the field at all I get the error message “Only letters and numbers allowed”. Is there a workaround for this? In fact, this error even applies to the group settings, it wont allow “.” at all.

+1 yes please!

I’m trying to sort this out it’s seem to be not working!

These are my setting and I’m using cloud instead of duckdns


Thanks for updating the Garmin app for Fenix 6. Works great!


I just installed hassiq on my garmin vivoactive 3 music.
After setting up everything, the connect app prompted me to sign in, but it only loaded a blank page without me being able to complete the sign in process.
Using the long live access token method, I got an error code 1001.

I went through the thread, I did not see any report that is similar to mine. Anything else that I can try?

Hey there! I don’ t know how I screwed setting this up, once I got it running WoW!!

I got it to work with Nabu Casa and a long lived token!!

@kbtang88, did you get this working? If not try deleting the garmin: line in your file, you don’t need the domain, its just a group.

I have deleted that line and still not working

Here is my group config…


the group I put into the app config is:

1 Like

I will try that tomorrow

doesn’t work i have put the config that show on there and how about the garmin side?

What is the error you are seeing on the watch?

Thanks for the great work on hassiq. It used to work great for me. Now I tried to set it up again, after the authentication changes and I only get error -300. I’ve read that only https is supported by garmin these days but even when I put in a selfsigned certificate, I still get error -300. Is there anything else I need to configure or is there any way to get some more information about what the problem is?

Is the exact url you are putting into hassiq accessible from your phone?