Home Assistant interface for Garmin's Connect IQ platform

I tried restart phone and now it’s OK :wink: Thanks! It’s awesome! Good job.

1 Like

I am thinking about adding support to report temperature, heart rate, steps, the Garmin “move bar” and other measurements to HA.

In particular I am interested to detect the end of an Garmin activity, or the fact that I started to sleep as indicated by a lowered heart rate.

@alanf Do you see a chance to extend hassiq with a background process to send these measurements to HA? Or should we start a separate CIQ app?

@stv0g I’d love to see that functionality in HassIQ. I’m not sure when I would have the time to implement it, but any pull requests would be welcome!

I love this thanks for your great work, just added a few lights and it works perfectly!

1 Like

Just found this and wanted to tell that it’s working great! Keep up the good work @alanf :v:

1 Like

Any chance this can become available for the forerunner 945 as well?

took me a few minutes to get it right
i was convinced i had a group.lights - turns out i didnt.

troubleshooting for others - make sure your URL is correct and ensure the group you chose is actually valid.
everything else just works, and works well!

Any chance this can become available for the forerunner 945 as well?

if you have connectIQ for garmin then this should work

The latest update should add support for the most recent Garmin devices.

Thanks Alan, this is great. Appreciate it very much!

1 Like

Trying to get HassIQ working on Vivoactive 3. When I open the widget on the watch it displays “Status:0” for about one second and then the status changes to “Status:-300”.
HassIQ 1.0.9
Hass.io version 167 on Docker.
Host: http://192.168.x.x:8123
Visible Group: group.garmin (I have created a simple group in HA with one light item and HA has been restarted)
Long-Lived Acces Token: Using token created via Home Assitant interface

Any idea about what is wrong?

1 Like

I’m having the exact same issue. Any help?

@mabl, @kmgalanakis

-300 in ConnectIQ is a network request timeout. If you go to the exact same Host URL on your phone, does Hass come up?

Yes, in my case the host url responds properly when I’m accessing it using my phone.

It’s in the form of

Should it look like that, or…

Thanks for your reply. Yes Hass is working fine via the URL on my phone. I am using http and not https.

I’m unsure what is going on here, but in an effort to debug it, could either of you try not specifying a Long Lived Access Token, and see if it prompts you to log in on your phone?

If I remove LLAT then I get the following error in the Connect App when I open the HassIQ widget on the watch:

Webpage not available

The webpage at could not be loaded because:


It looks as if standard http ciq requests aren’t supported by the Garmin Android app.

You would need to move to https for your Hass install.

I have tried to use https://<ip> with a self signed certificate but that did not solve the “status: -300” error.
I solved the issue by:

  1. Enabling DuckDNS add-on in hass.io
  2. Adding a static host entry on my router (USG) which is pointing <mydomain>.duckdns.org to the local IP of the HA server - as I don’t want to expose HA on the internet.

I used the info from the site below to setup the static host entry on the USG https://gist.github.com/troyfontaine/a0a0098d6a8c333e5316ebf16db1c425 and the Android app About HA Client - native Android client for Home Assistant to test the connection. When I got the connection working with the “HA Client” it also worked with hassiq.


Thanks for the information!