Home Assistant iOS app not available in App Store

Tags: #<Tag:0x00007f739f1c13e8>

Hello together, I bought a new iPhone and wanted to install the home assistant iOS app from the German Apple app store. Suddenly the app no longer exists in the Apple App Store in Germany :pleading_face:? What’s going on there?

Same here in ios app store in France

Same here. I wanted to reinstall the App but now I can’t download it again.

I also just uninstalled the app and am a little confused as to why it has disappeard from the AppStore?!

Robbie has temporarily pulled it from the App Store due to an issue where it crashes on launch. He is planning to fix it over the weekend. From his Twitter:

I am aware that due to internal changes in a recent Home Assistant version, the iOS app is crashing for new users. I also know that sensors are broken for some that have an eSIM. I’m planning to fix both issues this week. Apologies to anyone experiencing this!

Tried to fix the issues tonight. Not as straightforward as I was hoping. I’ll finish it up this weekend. In the meantime, I’ve removed the app from the App Store until the fix is published.

If you’ve downloaded the app previously, you might be able to re-install it from the “Purchased” section of the App Store. Click your user profile image in the top right corner of the App Store and then near the top of this page it’ll have a “Purchased” menu item, and you can search for Home Assistant in there. Not sure if that’ll work but it’s worth a try.

Same problem from Dutch Appstore (Netherlands). I had to re-install it due to phone crash, and could not load it. However,…

@SeanM directions worked for me . I could re-install it by using his directions in previous post !
Many thanks.

grtz
John

It’s the same issue in the Netherlands

same here in US and Australia. just wait for Robbie then.

+1 for Austria.

Thanks Sean for the info. i have problems with my notifications. Do you know about Problems. Maybe it has the same reason? Greetings from Germany Jan

Any problems with notifications are unrelated to this issue. You can try some of these troubleshooting tips.

Same here in KSA I cannot download it, when it will be finished bro ?

Robbie has successfully built the app and uploaded it to the App Store. It has to be reviewed and approved by the App Store now, cannot give a timeframe on that part since it relies on Apple employees.

Will also be a very brief / limited beta of a few people just to make sure everything works ok.

If everything goes smoothly, it should be back on the store and bug-free very very soon :slight_smile:

5 Likes

Is there a chance it’ll fix the stuttering I’m experiencing in dashboard? Maybe it’s only related to a custom frontend card but it started with 110.5

I also have the stuttering in the dashboard. For me it started when i went from 110.1 to 110.6 so the problem could have started with 110.5

Stuttering is solved with 0.110.7 in my case…

111.0b5 solved it for me.

Just waiting for the app to show back up in the App Store now.

1 Like

This worked for me! Thank you.

This is taking awefully long…