Home assistant is causing video playback issues on my PC

First post here.
I installed supervised HA on my media PC, which is running Ubuntu 20.04, using the following instructions:

HA itself is running great, but the issue is that any video content I am trying to play on this PC is not playing properly - it is choppy and stuttering. I tried VLC, Chrome, Firefox. Same problem on all of them.
Video issues get solved as soon as I stop docker.
My PC has an older i7 4770 CPU without a separate GPU.
Any ideas on how to solve this video playback issue?
Thank you!


What do the logs from such players tell you?

So is it docker or is it home assistant yjay is making the problem?

You do realise that supervised on ubuntu is totally unsupported?

Personally I wouldn’t mix my media player with my home controller, but each to their own :slight_smile:

What media server software? Maybe it can’t handle both process

I gave up on this installation method. I just installed OS under KVM. So far no issues.

Update: I was able to figure out the reason for this issue: it is the audio container that exclusively takes over the sound card, so any video player is not able to open it and thus getting stuck.
As a workaround, here is what I do to get video back:

  1. Open video player so it tries opening audio
  2. Using portainer add on, or any other method, stop the hass audio container
  3. At that point, the video player is able to get hold of the audio and starts working
  4. Hass audio contaner comes up and sets the volume at 100%. You need to be ready to drop it back to normal value
  5. After this, you can watch the video
    This method does not survive reboot.

I observed the same issue not only on Ubuntu but also on Debian 11, which is officially supported.