Home Assistant is making my PC non responsive

I understand, that’s the next attempt if I can’t get this working. I took a photo of the log this time to see if it narrows down the issue https://imgur.com/a/Gf1UfcD

It id failing on networking. Try changing the network emulation in virtualbox.

Tried changing the adapter, also unplugged and replugged in my wifi/bluetooth card testing both unplugged and plugged in as i only brought that last week, just to rule it out. Tried a restore backup from before the 22nd as well. No dice. Think it might be time to move off virtual box and onto a Pi or something

I would agree a Pi (with HassOS) is WAAAAY easier.
Re: the SSD on a Pi4 - Ive been running that way for about 9 months (Note: This is Supervised, not HassOS)
It was really tricky to set up though with the uSD just acting as a boot loader and I wasn’t very impressed about the hoops required
Then RPF launched the stable boot loader (EFT switch) It then became a lot easier,
I’m now considering @kanga_who 's option of running a Pi4b with SSD on Debian, he always writes good guides and MORE importantly keeps them up to date - 5 stars in my book

Krispkiwi, youtube videos are terrible at keeping current, they always seem about 2 releases out of date and seem to cause more trouble than they are worth. Go to a reliable source


Just tried the install wit the latest virtual machine installation instructions from the home assistant website, still getting the same error. https://imgur.com/a/UtKaDrG A person on reddit has asked me to turn off the USB but I’m also getting a ““The usb controller emulation is not currently enabled on the USB page. This is needed to support an emulated USB pointing device. It will be enabled automatically if you confirm your changes”” error at the bottom for that.

Update, also tried an installation on my laptop, same error.

Hey everyone, big update in narrowing this down. I tested an ISP router to see if it was perhaps a network issue but related to my Unifi setup rather than anything in the VM settings and upon trying to launch when connected to my ISPs router, Home assistant worked. So there’s something in my Unifi settings which is causing this error.

Another update:
If I run a Ubuntu Desktop Server in virtualbox I’m able to run home assistant on that server however it appears to be a lite version with no ability to upload snapshots. I’m not sure why going through a 3rd party machine and then launching the home assistant on that doesn’t cause the error but having it straight on my virtual machine causes it unless I use my ISP’s router.

You can make it officially supported if you install it on top of debian and some other stuff needs to be adjusted as well.

1 Like

I wonder who flagged this ???

I would suggest you follow your own advice and do some reading before making a false statement like this.

I would also suggest that perhaps it would be good idea to at least consider listening to one of the most active and helpful members of the community who takes sometimes hours out of his day to help people, like you.

However, if you wish to just do your own things because, “everyone’s entitled to their own preferred way of running home assistant”, then good luck to you, but don’t expect people to jump to help you when you face a problem.


First and foremost the very link said member linked states as follows " Please keep in mind that currently this installation method is not officially supported by the Home Assistant team"

Secondly the fact you think that’s support is amazing. Amazing in the sense that I would fire any of my employees in a heartbeat for treating a customer that way. If a customer came into the store and said "I’d like support getting this working on my phone and my employee not only instead tried to sell them a different product they weren’t after when their original product is advertised to work with said aspect of the device and then a week later came back after troubleshooting on their own to update a trouble ticket just to be told “For god sake why don’t you just buy the new product” yeah they’d be on the unemployment line very quickly.

Thirdly this isn’t “Doing my own thing” Virtual machines are an officially supported form of home assistant.

Oh dear.

I’ve consumed the best part of a bottle of red wine over dinner tonight, so I’ll do my best to respond.

He linked that particular guide based on the statement you made about using Ubuntu. Ubuntu use isn’t supported, Supervised is. I’m very well aware of what the guide states, I authored it, funnily enough with some help from Nick which you’ll see noted at the bottom. Again, do the reading and educate yourself on installation methods and what is and isn’t considered supported.

I didn’t state it was support.

Home Assistant is a free product, with an immensely talented community that provides free advice and suggestions etc. We are not your employees and are offering our advice and suggestions, for free. No one here owes you anything, you are not entitled to a particular level of service as there is no exchange of funds for service. You are being offered the advice of those very experienced with the use of this software, I would again make the suggestion that you consider following it.

Correct, they are, however, your mileage may vary based on the machine type you use, the environment you run your system in, etc. The only almost bulletproof installation methods are image based installs on a Pi.


To clarify:

I was running Ubuntu as the guest host which was the guide I was following at the time, I’ve since updated this to Linux 64 as per the guides without any change to the issue. Not actually running a Ubuntu server, I’ve done that since to test it but not as a real attempt at getting HA working.

I never said anyone owes me anything nor even implied it and I most certainly didn’t suggest you were my employees. That example was given to demonstrate why what was said was not only not help or support but also rude and irrelevant to the request. If you go "hey I’m looking to get HA working on a PI and someone says meh go buy a nas and run it on there, that reply is less than unhelpful especially if you follow it up with “Go do as you were told and buy a nas” the fact you’re even trying to defend that…

I’m more than willing to follow all suggestions relevant to my query.

So it appears then that your issue is environmental, not to do with HA. Also, what is “Linux 64”?

By providing an example that is based on monetary exchange for service to argue against something, you are indeed implying that. It was a poor example.

No suggestion was made by Nick that a purchase of a new product was required - an alternative installation method was suggested.

You are looking for a solution to the problem you have. A suggestion was made, you can choose to follow it, or not. You could take the time to look at the profile of the person who made the suggestions and see how prolifically he posts and helps people on the forums, and perhaps that might give you pause to consider that his suggestion may be a good one.

Or, you could continue to argue against it, be offended and flag posts.

1 Like

Linux 64 is the recommendation for the guest host in the VM instructions “For VirtualBox create a new virtual machine, select “Other Linux (64Bit)” I had it as Ubuntu 64. Both have the same result. The issue appears to be a network related one. There’s an issue somewhere with how the home assistant virtual machine is interacting with my ubiquiti unifi network as other routers don’t have the same issue. I’ve checked firewalls, I’ve checked other settings without success. I’ve created other VMs and tested them and even tested home assistant on the other VMs with no problems. It’s specifically the home assistant VDI and Unifi. Both virtualbox and Ubiquiti are puzzled at the logs as well.

The example was demonstrating what is considered as help and what is considered rude and it isn’t. I was seeking help specifically troubleshooting one form of installation method that I am comfortable with and had used previously. Suggesting an alternative installation and then being rude when I come back updating my thread with updates is less than helpful.

Yet they might have an answer that will help us to help you. Yet you don’t post them.

A what? Never heard of ubuntu desktop server, but I may have missed that release.

You appear to be tying yourself in knots running haos inside ubuntu inside virtualbox inside ubuntu.

I have suggested using a different network emulation inside vbox. I know you said you did so, but haven’t said what network emulation you are actually running?

1 Like

Also I looked again at this pic https://imgur.com/a/Gf1UfcD

Your caption refers to windows? I missed that earlier. Where does windows fit in? You haven’t mentioned it so far.

Curiouser and curiouser…

Hey Nick

With the logs, some of them include private data ubiquiti has told me not to publish elsewhere as they’re very long but contain private information but here but the ones Virtualbox requested https://forums.virtualbox.org/viewtopic.php?f=6&t=100843

I’ve managed to narrow it down further than I had before. After a bit of trial and error with Ubiquiti it’s been narrowed down to a LAN issue. If I use the ethernet cable into Lan 2 on my switch and run home assistant, the computer freezes entirely. If I have the desktop plugged directly into Lan 1 on the USG router, it still becomes non responsive however not as much that it freezes entirely I can still use the PC and home assistant in the browser will attempt to load although it will just continue to attempt to load, it never loads in fully. After putting my WiFi/Bluetooth card back into my PC and instead of using the ethernet cable, connecting the home assistant to the wireless card under the network settings and connecting to my wireless network on my PC itself in addition to my lan network on the PC. Home assistant loads and there’s no freezing so that narrows the issue down even further to being a lan issue. So at the moment home assistant is running over my WiFi connection and my PC itself is running over the Lan. The docs do recommend home assistant runs over the lan but getting closer and closer to the root cause. I have to say it’s nice to see my UI again.

For the Unbuntu desktop server, It’s this here: https://ubuntu.com/download/desktop basically you can load up a mini PC inside of virtualbox. It has home assistant in the app store on it too although it appears to be home assistant lite as it doesn’t have as much options. For example you don’t appear to be able to load or save snapshots.

With Windows, I’m running virtualbox on my desktop which is windows 10. So the PC is windows, the guest host in the set up for home assistant on the virtualbox is linux - other linux 64 bit. When the computer freezes after running home assistant via the lan when plugged into the switch, I’ve more often than not needed to restart the entire computer to get it functional again.

Good to hear that you might be working out the issue. It does indeed seem to be an operating environment issue, not a HA issue.

This link is to Ubuntu Desktop, which is different to Ubuntu Server, hence why the question was asked. They are different versions of Ubuntu, and neither are called “Ubuntu Desktop Server”.

Bad idea. Don’t try and install HA in this way, especially with the issues you seem to be facing.

There is no installation type named Home Assistant Lite. Again, I would suggest you read up on the current installation methods. An excellent post HERE explains each method.

Do you any other old PC or laptop laying around you could try to install on? I would suggest it would be a good idea to try running on a dedicated machine if possible and see if you continue to face the same problems. It doesn’t have to be good/new/high-powered to run HA well. I’ve testing running HA OS with Proxmox and Supervised with Debian on a 10 year old Dell dual core laptop with 2gb RAM, which runs things adequately.

Still unanswered.