Home Assistant just stops working every couple of days

Pretty much the title.

Since a couple of weeks HA (32bit on Raspberry Pi3 B+) stops working - first partially (sensors stop to report values - or more likely HA doesn’t record them) and then I can’t even access it through the browser or app.

Usually it starts by automations (or NodeRed flows) taking longer than usual to react - for example simply turning lights on or off.

What could be the problem? where could I look for errors? in the supervisor > system > supervisor logs everything is green - also the logs seem to only go back to the system boot…

I’ll upgrade to a RPi4 soon anyway and will completely set HA up from scratch (right now I’ve always just updated since 0.75 or something) - but until then, it has to work! it’s not fun comming home to a house thats almost 40°C, because HA stopped working and left the heaters on for a couple of hours :confused:

EDIT: it runs from a completely new (about 2 weeks) SANDISK Extreme microSDXC UHS-I 64 GB A2 SD card and the recorder is set up to store it’s stuff on a NAS… so I doubt it’s a failing SD card

Have a look at the memory and cpu usage in the supervisor system panel when things start slowing down. This does not auto-refresh so you have to either navigate away and back or refresh the page for an update.

A better idea would be to install some system monitor sensors and keep an eye on them (or get them to send you notifications using numeric state triggered automations).

Usually I only realize something is going on, when I come home to a freezing or hot house and can’t log in any more - and then I remember that light switches did feel slow lately. So I wans’t able to look at memory or cpu usage in that situation. I have to pull the plug and then everything works as if nothing has happened.

I’ll do that - didn’t realize this existed.

Anywhere else I can find system logs from the time the sensors stoped working?

Not if you have restarted.

hmm ok I’ll just log the system monitor for now

Not sure if that’s relevant - but Memory usage slowly but steadily increases …

there was one restart at 14:45 - Network usage is high when I looked at the logs - local disk usage is constat.

Only the RAM seem quite high to me :thinking:

Yeah that’s probably the issue. You have something with a memory leak.

Do you use onvif cameras by any chance?

Nope - only have one camera which runs on another RPi (motioneye) and is not recorded, but takes 2 pictures a day

  - platform: mjpeg
    name: Camera
    authentication: basic
    username: admin
    password: ***

HI All,

@Farnsworth was just wondering if this issue was solved I seem to have the same thing going on here.

I “solved” the issue by buying an Odroid N2+ … never had any problems since