Home Assistant keeps stopping on login - Android app

It worked yesterday, but I’ve had to do a factory reset on my tablet.
I’ve installed the root certificates from Let’s Encrypt, but apart from that I’ve got a completely vanilla cheap tablet.

  • Welcome to Home Assistant App
  • Select Your Home Assistant Server - https://etc
  • Login screen user / pass → Login
  • Connect to Home Assistant, Device Name … Continue
  • “Home Assistant has stopped”, Open App Again

Version Mar 30 2024. Android 12.0, 1 5, 2023

if you were able to login and get to the device name screen then some other error must be happening. Please submit an issue on github and try to get teh logcat logs so the team can investigate. Please make sure to complete teh issue template


I’ve had the exact same issue on an old tablet. I’ve reverted to the previous app/apk version (2024.3.4) and it’s fixed the issue.
The tablet is an old Samsung Galaxy tab S2, still running Android 7 (as Samsung don’t bother updating older devices.) I wonder if this is the issue?


Your issue is unrelated to the OP. Your issue will be fixed in the next release.


I am allso having issue where app is crashing on login on an old Android tablet. I’ve reverted to the previous app/apk version (2024.3.4) and it’s fixed the issue.

Can’t revert, as I did a deinstall and reinstall. Also Android 7; my phone from 2018 is still quite new and I don’t plan to get a new one soon. Looking forward to dskohouki’s promise of a fix.

I have the same problem on a Galaxy S2, since the last update.

Same thing here. Came to notice this morning that my wall mounted Samsung TabA android tablet was saying “Home Assistant keeps stopping”. Downloaded an older APK and running fine now. Must be something with the latest Android app not playing nice with my old tablet.

I’ve managed to extract my logfiles, so I’ve posted a bug on github

1 Like

Guys if you read my post a day ago you will see we are aware and a fix will be released soon. Duplicate bugs are not necessary.


Quite. I was glad to see it, thank you. And sorry for mangling your name in my first answer.

Thank you for the new version - my Galaxy S2 running Android 7.0 is working fine again with the Companion App V2024.4.1-full :+1:


Same here. Cheers!

Just writing to say thank you. Good job.

Same issue with an Oneplus 5T on Android 11 (OOS 10.0.1).
The newest “Companion App V2024.4.1-full” crashes always during login.
A downgrade to “2024.3.4” fixed it, and also afterwards upgrading to the play store version “Companion App V2024.4.1-full” (whcih crashed) worked.


sorry but that is 100% not the same issue, issue impacted devices on android 7 and below becuase an updated dependency was not compatible with those versions.

the crash logs wouldve been helpful in this case but glad you got it working.

It sounds very similar.
Sorry, had no time to debug it further.
Just want to let the other users know that the workaround also worked for me.