Home Assistant migration - ZHA & Conbee II failure

TLDR: Migrated my Hass OS installation from an x86 PC running VMware ESXi to an N100 mini PC running Proxmox. Everything worked a treat except for my ZHA/Conbee II setup. Deconz/Phoscon works but ZHA fails during setup.

The longer version:
So a few weeks ago i setup a mini PC with the aim of replacing my aging i5 5th gen running VMware’s ESXi which ran two VM’s, one of them for Home Assistant. The setup of the mini PC went without any problems and i had HA running in parallel with the old machine. I restored a backup on the new machine from the older installation and verified that everything worked. When i was satisfied that everything was functioning as expected i moved the Conbee II stick over to the mini PC and exposed it to the HA VM in Proxmox.

Quite frankly i expected this to go as buttery smooth as everything had up to this point, however it did not. The situation is that the Conbee stick is truly forwarded to the HA VM and is detected by it.

I can communicate with it using Deconz and Phoscon. However when i try to set it up using ZHA like before i get an error message.


Looking at the logs i get an error regarding a lost serial connection.


What i have tried sofar:

  1. Tried multiple methods of forwarding the Conbee stick to HA.
  2. Added a USB extension. Read on some forum that the Conbee is susceptible to interference from USB3 ports and moving it away from the ports helps.
  3. Every combination of removal/resetting/rebooting the Conbee and HA i can think of.
  4. Ordered a Sonoff Zigbee dongle, but it probably won’t be here for another couple of weeks.

Can anyone offer any thoughts on the issue?

You disabled Deconz/Phoscon ?


Yeah, you can not connect deCONZ/Phoscon and ZHA to the same Zigbee Coordinaor adapter.

Zigbee Coordinator adapters/dongles are serial devices that only support one connection.

Are you using deCONZ/Phoscon or the built-in native ZHA (Zigbee Home Automation) integration?

Or are you trying to migrate your ConBee II Zigbee Coordinator from deCONZ/Phoscon to ZHA?

If trying to migrate from deCONZ/Phoscon to ZHA then recommend migrate to new adapter, see:

If so then tip is to first perform a backup of Zigbee network + NVRAM inside deCONZ/Phoscon.

PS: Here is an old but probably still relevant thread that might help if having issues with backup:

You also did not not mention if using Home Assistant Operating System in VM or if using Home Assistant Container or other type installation under some other operatingsystem and container engine or else (as then you need to forward the USB port or serial device there too)?

Anyway, remembered that ConBee II (ConBee 2) should use either 38400 or 57600 baudrate (unsure which but it is not not 115200) + hardware flow control. Regardless, you also want to map it inside Home Assistant via its /dev/serial/by-id name as the serial device path (instead of /dev/ttyACM0) if possible, (i.e. a serial device patch that looks something like /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_..., check under System - > Hardware → ALL HARDWARE if using Home Assistant Operating System).

By the way, there might be some additional related tips here as well if migrating:

I am aware, my original post was not clear enough. Apologies.

To clarify on the old machine (box 1), i was running ZHA only. Setting up ZHA was my first task on box number 2 however i was not able to connect. Therefore i tried setting up Deconz and found that it could communicate with the Conbee stick. After that i disabled and removed Deconz.

I have since given up on migrating my network - it wasn’t very large anyway as i have most of my bulbs connected through HUE. I have reset the stick using Phoscon and now i am simply trying to setting up ZHA with the stick in a fresh state.

Regarding the VM it is running HASS OS without an intermediate layer. No containerization.

I have also tried to manually map the Conbee stick using the serial id, no luck there.

I’m not sure where i got that port speed from though. Have since tried both speeds with /dev/ttyACM0 with no luck. According to your post in the other thread its 57600, i will try that along with the direct path and report back.

Well I’ve made some progress. It appears that on the old machine the serial port was writable.


However this is not the case on the new box.


To anyone that finds this in the future, the issue was never solved. This is definitely a Conbee II issue as the Sonoff antenna worked on the first go around using exactly the same methods.