Home Assistant no longer reachable after update

Tags: #<Tag:0x00007fc407f5c710> #<Tag:0x00007fc407f5c468>

I noticed today that I had both an update for Home Assistant Core (I believe to 2021.5.1). After clicking update and waiting for a backup snapshot to be created, the screen just went back to the main Supervisor screen with no indication of an update taking place.

However, when I refreshed the page, I got a “This site can’t be reached”, so I figured the update must have been taking place. After about 3 hours (I went out for a bit), I tried to access HA again, but I still got the same “This site can’t be reached” message.

I tried reaching my Raspberry Pi through Putty/SSH, but I now get a “Network error: connection refused” message. After waiting for another half hour, I decided to unplug the power and reboot the system. Pinging the IP gave me an indication when it was back up, so I refreshed the page again, and I am still not able to reach it.

I figured maybe something went wrong with the update, so I plugged the SD card into my pc to see if I could manually restore the snapshot, but I’m only able to access the hassos-boot partition, with no useful information.

Does anyone have any idea what is wrong and how I can restore my installation?

I am having the same issue, I hooked up a monitor to my Pi with a keyboard and mouse. It shows me its looking for an HA user and password. If I put mine in it says wrong pass… I am also looking to restore now to one of my saved snapshots…

Same here. I have the Samba Share add-on installed and the home-assistant.log reads this:

2021-05-11 17:24:10 WARNING (Recorder) [homeassistant.components.recorder.util] The system could not validate that the sqlite3 database at //config/home-assistant_v2.db was shutdown cleanly 2021-05-11 17:24:11 WARNING (Recorder) [homeassistant.components.recorder.util] Ended unfinished session (id=34 from 2021-05-12 00:15:46.863416)

I deleted Home-assistant_v2.db and she fired up.

To access your old config data you can use a Linux system, i.e. a Raspberry Pi with Raspberry OS. It will mount the data partition too when you insert the SD card.
I recommend that you steer away from SD and start using an SSD. SDs don’t cope well with HA’s constant disk writes to update it’s history database.

1 Like

I rebooted my modem and network and then the PI. Seems to have come back for me.

1 Like