Home Assistant not available suddenly


I have Home Assistant installed on RPi4. Yesterday evening it all worked with no problem. I did not do anything since then. And this morning I found out that HA is not available. Web interface is not responding and SSH is also not responding. So I tried restarting RPi4 simply by disconnecting it from power source. And still no change.

But I see HA connected to the network on my managed unifi switch and I actually also see some network traffic. But the IP address of HA is not responding even to ping. But it seems to me like at least something of HA is running, because I have email notifications for HACS updates and I got one notification in the night (OK, might be before the issue), but got another notification today after I restarted RPi4. So at least something is running.

What can be wrong? What can I do to troubleshoot and hopefully fix the issue?

Attach a display, reboot, observe.

That is weird. I attached a display and could see that everything is fine. But for some reason, HA changed its static IP to DHCP. So the only problem was that HA was running on a different IP. Changed back to static and everything is up and running.

I recommend you configure your DHCP server / router to assign the same IP to the Pi every time.

1 Like

That is what I just did :slight_smile: