Home Assistant not reachable in the morning

Hello,

One of my Android devices can’t log into Home Assistant every morning. I need to turn off Wifi and connect through mobile data. After this it is working fine with wifi until the next morning.
How can I debug this? The mobile app is only giving me a popup like: Can’t connect.
But I don’t know why. An other Android device is working fine and on iPhone the problem doesn’t exist either.

I run home assitant in a docker container and have https enabled with certificates and have an open port for home assistant in my router.

Whats the router you are using??

most of then that are free bee dont do wifi that well

and plus some of thoses free bee can only handle 30 thing

I have a fritzbox 7590 router

It sounds like the wifi on the phone is sleeping. If you open another app are you able to connect to the internet?

Yes this is working. I can browse in the internet and all other apps are working. As I said I only have the problem on one device. But the app logs aren’t helping me either

FritzBoxes are sometimes very **** :wink: Ask how I know…

One setting that made a lot of problems, was the DNS-Rebind-Schutz (assuming you use german). You can find it under Heimnetz->Netzwerk->Netzwerkeinstellungen->erweiterte Einstellungen->DNS-Rebind-Schutz.

Try setting both, the internal IP address and the local mDNS domain (like .local) for your HA instance.

pi.hole
192.168.178.xxx

Sorry for the late reaction. I tried that with my domain and my machines IPv4 but it didn’t work. Do I also have to enter the IPv6 adress? My internet provider doesn’t grant me IPv4 option.
Since I have certificates for my domain name I can’t reach home assistant through the IP adress.