Home Assistant not running at full service after VM shutdown and power-on

I am quite new to HA, but I was running it for the last week with no issues and started building it up for my network. Have spent a lot of hours for the last 7 days. Today I had to do a VM shutdown and power on, after this HA is not opening up port 8123.

HA runs as a VM in Synology VMM on my NAS. It was on latest SW even before the shutdown. What I observe if I run a port scan for the IP is using is that following ports are ONLY open.

For typical operation I would expect on top of the above the following open ports 1400 (I think this is used for Sonos) and of course 8123 that is used for the GUI. However, none of these ports are up and in listen mode. Since HA is not listening on port 8123 it refuses any http connection for the GUI. This is not a firewall issue or routing issue. Is probably related with the HA VM not bringing up all services during boot. The banner command on the HA CLI seems fine as per screenshot. Tried supervisor repair and restarts but no luck.

Observer also looks ok as per screenshot

If I create a new HA VM/installation from scratch it works fine and I can access the GUI but unfortunately I made the mistake of not creating a backup so trying to see if there is any option avoid spending endless hours again to recreate my config.

Any guidance is much appreciated. The obvious other option is to start from zero again but my concern is that this issue might happen again and I dont want to keep creating new HA installs and loading backups everytime the VM goes down or restarts (intentionally, e.g. NAS upgrade/restart) or un-planned for whatever reason.

It can take a while. The supervisor comes up first and eventually bring up core. When my Proxmox is rebooted, it’s about 20-25 minutes after power up before I have access to Home Assistant again. The Home Assistant VM comes up within 5 minutes of power on, but it takes a further 15-20 minutes before it’s actually usable.

I just leave it and it comes up on it’s own, despite usually initially complaining about not completing the setup stage of startup.

I have left it for almost 1h with no luck, but will leave it over-night and see, Thanks!

Man, that’s patience. My HA instance is up and running in 2-3 mins after rebooting the vm. I guess your system is much larger.

Oh no if it’s taking an hour - it’s not working.
Have you tried typing login to see if you get a root shell?

Rebooting JUST the Home Assistant VM, it takes about 5-10 minutes to come up. It’s just much much longer when it’s the whole Proxmox host that has been rebooted. And typically I have to reboot the HA VM once it has fully come up because it usually has lots of messages about things not loading properly. I might need to move the boot order of the VM to the end of the list so it comes up after everything else has come up. At the moment it comes up quite early, but after Pi Hole, MQTT and MariaDB.

yes login works, I can get to the OS directories. However, when I did run core check I got below but I dont know how to translate this error message and try to fix it


Oh, got it. Yeah, rebooting the host will surely take time. I avoid doing that like the pest.

You need to post your config so we can look for the error.
Do you have the Samba addon installed?

Thanks for all your help, my configuration.yaml is very simple as per below screenshot. I dont recall adding Samba addon

OK - you can remove the entire auth_mfa_modules part because it is autoloaded if that is not part of configuration.yaml.

But also -type is not the same as - type notice the space, super important in YAML.

Thanks so much for everything, system is up again!!

1 Like