Home Assistant not sending data to remote InfluxDB since 2024.4.x

Hi All,

I’ve noticed since one of the 2024.4.x releases that Home Assistant no longer sends data to my remote influxDB instance. Just wondering if anything has changed. I set up a new v2 instance yesterday and I have set it up as per the docs - but its still not receiving any data. Code as follows:

influxdb:
  api_version: 2
  ssl: false
  host: <ip redacted>
  port: 8086
  token: <redacted>
  organization: <16 digit code>
  bucket: homeassistant
  tags:
    source: HA
  tags_attributes:
    - friendly_name
  include:
    domains:
      - sensor
      - binary_sensor
      - sun

I’m not seeing anything in the logs - so I’m a bit stuck - any ideas? :slight_smile:

Thanks
Leacho

1 Like

Same issue here. After core_2024.4.2 the data stopped and I got a error on the logs.

Logger: homeassistant.components.influxdb
Source: components/influxdb/init.py:591
integration: InfluxDB (documentation, issues)
First occurred: April 14, 2024 at 21:57:09 (1 occurrences)
Last logged: April 14, 2024 at 21:57:09

Cannot connect to InfluxDB due to ‘[Errno 30] Read-only file system’. Please check that the provided connection details (host, port, etc.) are correct and that your InfluxDB server is running and accessible.

My config is almost the same, except I use SSL and an exclude filter instead of your include filter.

Hello,

i have the same problem here.
Nothing changed except homeassistant updates.

kind regards

Exact same issue here. I updated from 2024.4.2 to 2024.4.3 on the 18th, and on that exact date Influxdb stopped receiving data. A reboot of both the HomeAssistant machine and the InfluxDB server didn’t help.

So I downgraded HA back to 2024.4.2 via CLI:

ha core update --version 2024.4.2

When it was done rebooting, it started working again right away.

2 Likes

Same problem here and solved by rolling back from 2024.4.3 to 2024.4.2 like @R86 suggested! Thanks mate!

1 Like

Yet no one has posted an issue on GitHub. Wth?

1 Like

Thanks for all the replies, confirmed that rolling back to 2024.4.2 is good - I’ll raise a ticket on Github now that I know its not just me :slight_smile:

3 Likes

Thanks, this worked

Thank god I found your post, I had to do a complete restore of my HA, and did an update as well, and was going crazy because InfluxDB was not working anymore…
So I can confirm the issue for InfluxDB 5.0.0 and Core2024.4.4,
Supervisor2024.04.0