Home Assistant not showing in Google Assistant link list?

I’ve been trying to make Home Assistant work with Google Assistant, because IFTTT is limiting me to 3 custom applets. It works just fine with my personal account, but I use a separate Google Account for my physical Google devices. The thing is, when I go to the add list, it’s not showing up. I’ve tried multiple times, but it doesn’t work with the separate one. Any ideas? I’m free to try a bit of troubleshooting.

I have the same problem. Home assistant not showing up in linked service’s in the Google home app. I search for it, log in, allow control, I get the message regarding linking service’s then it goes back to the previous screen. So I again select ‘work’s with Google’ expecting to see it there as a linked service, but it isn’t?
I tried everything I can think of short of uninstalling/reinstalling the Google home app.

Things still seem to work ok but it’s bugging the hell out of me.

Coincidentally this seem to accurr around the same time two of my Google speaker groups went AWAL.
I’m used to my speaker groups being up and down but two of them have just disappeared.
The device’s exist but to to ‘groups’ it’s like they don’t exist, and if I try and setup another group 3 device’s are missing?

I understood everything but this bit. What do you mean?

Well at this moment I can see my kitchen TV in my Google home app I can connect to it it and view that it is ambient mode at the moment just displaying photos. However there is no option to play music. And in my assistant settings my kitchen TV apparently doesn’t exist. Nore can i put it in a speaker group. However occasionally Spotify can see it and stream music to it. And home assistant and push music to it. And home assistant will also push text to speech to it. It has been working fine for ages but today it just will not play ball.
I wouldn’t mind but I’m even using the app on a pixel which is a Google product.

If you look on the internet ( Chromecast with Google TV issue may break speaker groups - 9to5Google )this speaker group thing is a massive problem with Google even recently acknowledging the issues. Apparently they have said it is something to do with having one of the new Chromecast TV devices on your network being part of the speaker group. If I’m honest I think these problems started when I added that device.

Also I don’t actually think it has anything to to do with this home assistant service link problem and believe it to be completely unconnected it just seems to be coincidental

Google really annoys me because they always get so close but can never get it right which is astonishing for such a big organisation. Instead of making things right they just bin them.

And to be honest it wouldn’t surprise me if in 5-years time Google stops supporting this whole home thing altogether and none of your speaker devices will work.

On another note I just tried linking my home assistant service through the home control page on the the Google assistant app instead of the Google home app. And you actually get a message saying your account link has been successful however it still does not show up in the the linked services list.
And also now when I asked Google assistant to sync devices it will sync all of my my services but then replies that it cannot what link the nabu casa account and only the person that first linked the service can can sync devices. Well I was the person that originally set it up, and now it won’t let me sync devices. I’ve also been checking a few things and all my routines, lights and switches seem to work ok. Also all my entity’s are showing up in in Google when I try to make a routine so it seems to be working just not displaying it in the linked service’s list.

Wait, are you using Nabu Casa or your own Google Cloud setup?

Nabu Casa.

You have me thinking now.
If I am using nabu casa and you are using your own cloud setup yet we both have the same problem it’s almost suggests that the issue is with Google and not the our setups.

This morning all my speaker groups are back and working??? :thinking:

Well I wasn’t able to get it working on the shared Google account for the devices, but I was able to get it to work on my own account, and I probably could share the service with the shared one.

Quick interesting one for you here. I think this answers my previous question. I don’t think it is a fault with the services/skills I think it is a fault with Google. I’ve just tried to link another service from a smartwatch that I have and that has exactly the same behaviour. Says linked successful however no linked service listed in the link services list.
However I think it is worked because I’m now able to control my devices from my SmartWatch.

I was hoping it was a home assistant problem because somebody would come up with a solution very quickly however now that I believe it’s a Google problem I don’t hold out any hope of it ever being fixed. They don’t seem to fix anything. They will probably just ignore it until the next products comes along.

PS Two of my speaker groups are missing again today :thinking: