Home Assistant not starting anymore


My home assistant supervised was running fine on a raspberry pi 4b.
Yesterday, I noticed that some entities were not available anymore and that the names on the side tab were strange, like they were variable names (eg: dev_tools instead of “Strumenti per sviluppatori” /“Developer Tools”).

The system was still, I was out of town for many days so once I noticed it as I came back I rebooted and now Is unreachable. I thought it was a space issue, since many videos were recorded in the meantime, but I deleted them and nothing changed, here is disk space:

/dev/root          29653M 25192M     3209M  89% /
devtmpfs            1759M     0M     1759M   0% /dev
tmpfs               1920M     0M     1920M   0% /dev/shm
tmpfs               1920M     9M     1911M   1% /run
tmpfs                  5M     1M        5M   1% /run/lock
tmpfs               1920M     0M     1920M   0% /sys/fs/cgroup
/dev/mmcblk0p1       253M    50M      203M  20% /boot
tmpfs                384M     0M      384M   0% /run/user/1000

Logging into the raspberry and checking via ssh the status:

sudo systemctl status hassio-supervisor

I get:

● hassio-supervisor.service - Hass.io supervisor
   Loaded: loaded (/etc/systemd/system/hassio-supervisor.service; enabled; vendor preset: enabled)
   Active: inactive (dead)

giu 10 10:35:28 raspberrypi systemd[1]: Dependency failed for Hass.io supervisor.
giu 10 10:35:28 raspberrypi systemd[1]: hassio-supervisor.service: Job hassio-supervisor.service/start failed with result 'dependency'.

So i tried:

sudo journalctl -fu [email protected]

Which gets me:

giu 10 10:33:57 raspberrypi systemd[488]: [email protected]: Failed to determine user credentials: No such process
giu 10 10:33:57 raspberrypi systemd[488]: [email protected]: Failed at step USER spawning /srv/homeassistant/bin/hass: No such process
giu 10 10:33:57 raspberrypi systemd[1]: Started Home Assistant.
giu 10 10:33:57 raspberrypi systemd[1]: [email protected]: Main process exited, code=exited, status=217/USER
giu 10 10:33:57 raspberrypi systemd[1]: [email protected]: Failed with result 'exit-code'.

So guessing it’s something with the used, I noticed that the system:

sudo nano /etc/systemd/system/[email protected]


Description=Home Assistant

ExecStart=/srv/homeassistant/bin/hass -c "/home/homeassistant/.homeassistant"


Is that user normal? I expected “homeassistant”, but by trying:

id homeassistant

It does not exist. Can I fix it manually?

A service name in the form [email protected] actually means: start the [email protected] withe the homeassistant parameter.

%i will be replaced by the parameter.

Now, if that homeassistant user somehow disappeared, it won’t work, indeed.

would it be sufficient to create it?

If you use the supervised installation method, you’re supposed to be able to answer that question yourself.
We don’t know (nor do we want to know, to be clear) that system.

I may have been wrong using that installation method in the first place, I recognize it, but I’ll still wait in case somebody else can be so kind to give me support even if I’m not a real super user


I ended up reinstalling home assistant from scratch, loading the back up again. Now it works