Home assistant not updating location from Android phone

I’ve recently started using Home Assistant on a Raspberry Pi4 and most things are working fine (Zigbee and ONVIF for example). For some of my automation I want to be able to tell if my wife and I are at home or not. I have an iPhone and I instantly got the HA app working on it and it reports back my location consistently and I can see where I am on a Lovelace map card.

My wife has a Samsung A71 and, although I’ve followed all the instructions I can find (and believe me I’ve googled lots!), I can only get it to update her location when she opens the app. Otherwise she’s locked in one location.

I’ve enabled all the location sensors, allowed the app to run in the background, given it access to location but it doesn’t update.


I came here to post almost the same thing. I am the sole user of HA in the house. I have been at work for 2 days. I haven’t come or gone. I uninstalled and reinstalled the app on my Pixel 4a that day while at work.

Yes, I have HA set to “Allow location all the time” on the phone.

While my issue is similar, it didn’t seem to warrant ANOTHER new thread.

Help the OP first.

turn off battery optimizations


Toggling the location settings under the app permissions caused my location to update. Thank you!

This just re-registers for location updates…without ensure everything in the link is properly set you may see the issue again when the app goes in the background

I have followed those instructions but it doesn’t work. She also has Life360 on her phone which works perfectly. I can stalk :slightly_smiling_face: track her no problem.

I’ve seen lots of similar comment around the www so I think there must be something the app is doing that isn’t quite right.

samsung devices are prone to killing smart apps, please ensure that you check any and all settings to ensure the app can run and stay in the background. check out dontkillmyapp.com for some tips.

if you truly think something is wrong then help us out and get the device logs as indicated on the same page. Take a look and see if the location request are still coming in.

1 Like

I’ve tried the suggestions on dontkillmyapp and this morning my wife has gone to work yet her location on my HA map hasn’t changed from last night. However, Life360 has her location correct. I’ve compared the settings for Life360 and the HA app and, as far as I can tell, they’re identical.

I’m happy to help as much as I can. You mention getting the device logs “as indicated on the same page” but I couldn’t see anything there. Can you point me more directly please.

I appreciate your help.

I’ve finally sorted it with many thanks for @dshokouhi’s help and patience. In summary:

Samsung phones have a feature called data saver. This disables apps from using the network in the background. You must disable this for your HA app to send your location back to HA in the background.

So even if you’ve successfully enabled your app in the background, without this setting change you’ll only get location updates when connected to wifi.


I have Data saver disabled and the app enabled for background use. However, the location still updates sporadically with no apparent pattern. The phone is Samsung Galaxy S10 Lite.

This fixed my problem

Starting fresh with the Android app

  1. Check that Home Assistant Core, the Android app and Android System WebView are up to date.
  2. Clear Storage or App data in Android app.
  3. In Home Assistant navigate to the Integrations Dashboard. Remove the mobile app entry for the device in question. If you see more than 1 remove them all.
  4. Restart Home Assistant.
  5. Log back into the Android app. If you have more than 1 device, make sure to rename the device during onboarding.

@Denis_I I had this same after last update of my phone. I did as @olesj recommended. It looks that had changed names of the entities. Before I had names on my phone language, but now they are in english.

I had a similar issue, that I fixed. my location on HA was set to Amsterdam. (I assume this is default) so it thought I was away all the time. maybe not the issue here, but I looked everywhere for a solution and this is the only thread that would pull up on Google. So maybe this will help someone down the road.


My samsung s phone had the same issue clear data and cashe on the ha app and start from scratch fixed my issue

This fixed my issue as well. Thanks!