Home Assistant on Pi 5 not restoring backup

Earlier today, I rebooted my home assistant instance and the raspberry pi gave the message: ‘deferred probe pending’(there is a github issue open for this here: Github). I had a backup from the day before so I flashed my SSD with home assistant os 11.4 and attemped to restore from my backup, and i got an error message: ‘Unknown error, see supervisor’. I then flashed my SSD with 11.3 and tried to restore the backup but i got the same message. I checked the logs in both installations and there were no messages there.
I’m running home assistant on a Pi 5 4GB with an SSD connected via a USB 3.0 to SATA adapter.



I had this error about a year ago. The reason was that the supervisor version of the backup was higher than the supervisor version of the target system.

My mistake was that I had beta updates activated when I created the backup.
Only when I activated beta updates on the target system as well and the supervisor versions become the same I was able to restore HA from the backup.

1 Like

That’s worked, thanks so much!