Home Assistant on Pi has died - DNS failing - Time & Date totally cactus suddenly

Hi there,
I’m having an issue with Home Assistant on Raspberry Pi 4B. It’s been running fine for nearly a year now. It’s the “Recommended” install of the OS + Supervisor.

I tried to update the other day and kept getting errors relating to no host internet connection. This seems to be DNS related. If I log in to the Pi using a keyboard/monitor and switch to an alternative TTY to get a shell. I can see that I can ping but if I try to us nslookup I get “connection refused”. Doesn’t matter if I try etc. systemd-resolved has complaints about being degraded.

Have tried to stop and restart it, it doesn’t make a difference. As an aside, the date is showing as 18th January (and it’s 13 Feb), which I think is likely causing much of this oddness…However, I’ll be damned if I can set the date! If I try to use timedatectl set-ntp false so I can set it manually, it tells me I have a Read Only file system. There are no options to set the date/time in the UI ( that I can see ).

I think it’s all related, and fear I may have some kind of corrupted SD card. Not sure if my recent installation of Frigate + MQTT Broker also hosted on same Pi could have accelerated the issue.

I have managed to copy my config dir, but before I blow away the Pi and figure out what next - Has anyone got any other ideas on how to fix this - can it be fixed?

I’m thinking I might try a Container only install after this on some “real” hardware that I have for other Docker work, which at least has an SSD. I know this means I lose the Supervisor and Add Ons, but honestly, I’d like a little more access/control to problem solve, and the cut down HA OS doesn’t make that easy.

Anyone have any ideas?
edit: I did fix the date…just the host internet issue persists.

It seems to be very similar to this, also unresolved issue