Home Assistant on RPi not working anymore

2 days ago i updated to OS 6.3 and Core 2021.9.3… I made 2 new integrations after that (Tibber and Verisure)… Everything seemed to work fine… Yesterday i was going to turn on the TV and switch off some lights and it took a long time and switches kept flicking back and forth… I tried restaring the Core and no improvement… Restarted the OS after that … and same problems… Checked the logs and took a screenshot… I did not have time to investigate… Today i tried to access the webpage and it was not there anymore…

The screenshot of the logs are not complete… But does anyone have any idea what this could be? Should i do a restore of a backup on a new SD card or could this be some easy fix that some update might have caused?

HA has worked flawlessly before… Never any issues with updates or such…

I started the HA up again after beeing down 2 days… connected a screen trying to see if i can see anything… It seemed to be starting up OK… Everything seems to work now.
I made a new backup since the old one were 4 days old and i had made some changes.

The new backup was 188 MB compared to the old backup that were 18MB … Strange…

home-assistant_v2.db is almost 1GB in size… Is this normal? In the old backup it was 222MB …

I have read up about the home-assistant_v2.db now… could it maybe be the Tibber integration that creates a lot of historical data that is filling the file? … Is there some way of limiting it?

Is there some way to see whats inside the file?

If you are not using the recorder integration configuration to limit what entities are being recorded you are recording everything to the database. Some integrations create a lot of data which will fill the database and kill your RPi performance in a hurry.

Only record data for entities that you really need historical data for.

1 Like

A Tibber Pulse or Watty will generate a lot of data from the Tibber integration.

You could also take a look at the throttle filter if you want to reduce the sampling rate:

1 Like

Go the same issue 2 hours ago. I found a solution. A very simple one.
I was on my way to re- build the whole system but found a solution on the way.
Burn an SD with regular RASPi OS 32 bits image using Imager.
Boot the Pi with it.
Run sudo raspi-config.
Verify the boot order is SD and after USB boot.
Simply run an update and you are done.
Return the USB SSD (USB3.0 for me) and all is back to normal.
Probably the 6.3 version is expecting the latest BIOS update. Mine was a month old before the updater.

Thanks… I need to look into that… in 4 days the database has grown from 0 up to 2,7 GB now… :frowning:

Are you running the Pulse or Watty? … If i filter the amount of data will it also update slowly on the screen?

I’m downloading the database now to have a look in it… I mean if the watty updates 2 times a second… Modifiying it to update 1 time every 2 second will create a lot less data… But what i would like is to update the webpage of HA maybe 1 time per second but log data less frequent. Do you know if that is possible?

What is a BIOS update gonna solve you mean?

Just had the same thing going from OS 6.3 to 6.4. The BIOS (RPi firmware through raspi-config) was not the issue.

It looks like after updating from 6.2 to 6.3 or from 6.3 to 6.4 when using external powered USB drive,
the RPI (4GB RAM RPi 4 in my case) does not detect a load on the the USB thus not enabling the ports (USB2.0 and USB3.0).
The trick is to disconnect the external power and re-boot. In my case it worked.
After boot ends re-connect the power and all is OK.
This assumes power supply does not hold an external USB drive so drive is externally powered.