Home Assistant on Synology with Synology VMM - no IP-address

Hey everybody,
I am totally new in the home assistant universe and tried to setup a home asisstant instance on my Synology (218+, 10BG RAM) but it doesn’t work.
First i tried to run it with docker but I found out that the docker image has no supervisor, so I tried to set up a virutal machine on Synology VMM with the .ova-Image from the Hoas website.

I followed the guide on the website and the image is booting but it doesn’t get any ip-address.

Things I’ve tried so far:

  • reinstalled VMM
  • checked if I used the latest ova-file
  • disabled ipv6-DHCP on my router (AVM Fritzbox)
  • tried to configure the network interface in the virtual machine via network update enp0s3 --ipv4-method auto --ipv6-method disabled

network info always gets me the following result:

To be honest, I have no idea where the 172.30.32.0 address comes from. My private network is 192.168.xxx.xxx and it doesn’t look like an apipa-address either.

Does anybody has any idea how to move on?

no one any idea? I am already thinking about buying an raspberry pi :see_no_evil:

Have you figured it out? Same problem here, not sure what’s going on. DHCP server is my EdgeRouter X. Somehow the HA VM does not get an IP.

Ihm, thanks for asking, because I forgot to post my solution here. I don’t know what solved the problem finally, but there were two things, I changed. The first thing was very stupid because on my router I limited the ip-adress-area to twenty adresses in the past and during the time more and more network devices moved into the network so there were no free IP-adress left. So I expanded the IP-adress-space.
The scond one was that my Synology was rebooted during an update.

As I mentioned before, I don‘t know for sure what fixed the problem but now it is working and I hope, that one of the two points will work for you.