Home Assistant on Virtual Box will not run properly

Hello community. I need help!!

I have been running Home Assistant Supervised on a Virtual Box running in Windows 10 for about 4 years now and it has been working flawlessly. But just last week out of the blue, it stopped working. I have been attempting to solve the problem since and am at my wit’s end. I have the Virtual machine running on a “D-drive” and I run backups to a Synology NAS regularly. I have restored a backup of the entire C-drive thinking maybe Windows had either gotten updated or one of the system files had gotten glitched. I restored a backup copy of the Virtual Box file and the hass vdi file thinking perhaps the virtual machine filed had gotten damaged. None of this worked. The virtual machine is getting an IP address from my router, and I can use putty to access it. But if I attempt to log into Home Assistant the connection was getting refused. And I have Samba installed in Debian, so I am able to see the entire system, both the system side as well as the usr share where hassio/Home Assistant resides. All the various config files look fine and I cannot find anything obvious that is missing.

I finally determined that Home Assistant was not running, so I was able to force it to start by going in Putty and executing the command “sudo docker restart homeassistant”. But after doing this, a lot of the Home Assistant is not functioning properly. If I go to integrations almost every installed integration is showing as “Failed setup, will retry”. If I go to Add-ons, I get this dialog box:


  1. If you just started, make sure you have given the Supervisor enough time to start.
  2. Check the observer.
  3. Try a reboot of the host.
  4. Check the system health.
  5. Ask for help.

One of the add-ons I run is Google Backup, but since I can’t get to the add-ons page, I cannot restore a backup from there.

Any help would be much appreciated.


Did you upgrade Virtualbox ?

Yes to 7.0.14 - not 7.0.16 which says there are issues. That said, I had upgraded before this issue began.

I very carefully dipped my toe into Virtualbox running on Pop!_OS for my RV and it’s running lightning fast, but I’m skeptical as I keep reading about people having issues with Virtualbox and HA. I only run HAOS and not under Windows so hopefully a bit simpler (and not a port). You could try spinning up a second VM and restoring to that to see if the VM itself is the problem, I’ve had that on VMWare before several times.

These types of issues are exactly why I not only get my HA backups but back up my VM’s every day too (my home runs on VMWare).

A follow up to my issue described above. When I go to xxx.xxx.xxx.xxx:4357, it tells me:

Home Assistant observer

Supervisor: Disconnected

I have googled this issue and everything find says it is related to Docker. However, I have rolled docker forward to the latest version, I have rolled forward to version 25, version 26 and back to 24. None of those attempts fixed the problem. What else can I try to fix this problem?