Home Assistant Operating System Update from 8.5 to 9.0 issue


I have HA on a VM in Proxmox working fine from long time.

HA is on 2022.09.4 and I tried to update OS from 8.5 to 9.0 but it does not seems to work.
In HA fromtend I see only “Connection lost…” message and after waiting 20 minutes, nothing happens.

I have done, as I always do, a VM Snapshot from Proxmox, so I can rollback to get HA work again, but what can I check and how?


1 Like

The same problem

Same problem here. Looking at the console in proxmox it only boots into UFI Shell.

Used the information from that thread to resolve my issue, linked here incase you guys run into the same troubles.

I have the same problem.
I cant access ssh for analysis the problem.
My environment is haos in virtualbox over w10.
I lost my instance again…
The haos dont have ipv4 address

Change the vm network to nat, start the vm haos.
In my environment haos freeze. Stop the vm,
change again vm network to bridge and start vm haos.
In my case, my system is ok!!!


I have a similar issue, with a big caveat, I have no backup at VM level.
In my case the VM reboots in a loop when trying to start the QEMU Agent.

I’ve tried to prevent it from starting by modifying something on the FS (by booting in an Alpine Linux) but:

  • I’m not sure how to do that in systemd without access to systemctl or other systemd related command
  • and i’m not sure how to do that with the SquashFS + overlay fs combination

Last resort, reintall a new VM with a fresh Hassio, which will entail other questions…

  • do i need to restart my zwave network from scratch ?
  • how do i reimport all my energy data ?
  • i’m sure others will pop up

Start reading from this post Installing Home Assistant OS using Proxmox 7 - #689 by patmann03 down. There’s a solution for HAOS in Proxmox

1 Like

Ah excellent !
I see the writeup is yours so thanks !
I had a clone, now I did a backup, and I’ll read on.

I’ll report back.

I don’t have a full backup from inside HA, so nothign to restore to… ( i thought they were full when you have a Core or OS update, but no, only partial)

the simpler would really have been to revert back that service of QEMU and see to make it boot (and do a full backup !!!)

now I guess I’ll restart from scratth with your scripts and see what data I can get back and how…