Home Assistant OS 10.2

I noticed that Home Assistant OS 10.2 was released today. The release notes mention a new kernel version (6.1.29) and some build root bumped to some new versions. Oh yes, and support for NFSv3. Should we install this right away? Does it fix some security issues? Can we safely skip it for now?

I updated after doing a full backup that I initiated. It did take long to boot after installation (~5 minutes). So far no issues to report.

Have tried the update, it goes on for a long time, the Raspberry Pi reboots, runs the fan at high speed for some time, but it still says i have version 10.1 and suggest i update.

Seems the update fails in some whay, but it does not say what went wrong.

What PI? PI 3 PI 4? Where is the OS on a eMAC or SSD, is USB involved? A lot of details missing for troubleshooting.

Hi all, Updated from 10.1 to 10.2 earlier this afternoon on a Generic x86-64 install on a SSD. After the update did the typical lost connection and went to reboot but never came back up. I tried rebooting several times and a couple of hard resets as well with no luck. I do have a recent backup that is retrievable on a ftp share but I can’t connect to the box at all, the server is not booting at all. Any suggestions?

Update - Not sure what I did, maybe just posting here was the trick but I plugged in a monitor and was getting ready to reinstall and low and behold we booted up :grinning_face_with_smiling_eyes:

I just updated from HAOS 10.1 to 10.2 and it went super quickly, no issues at all. I’m running on an i7 NUC, so the Generic x86-64 version.

If that was for me, it is a Raspberrypi 4 with 8Gb ram and a 32Gbyte SD-Card.

USB is populated with a skyconnect dongle only.

I found another thing…

I have 4 things that can be updated, if i update the other 3, they update…Very slowly (5 minutes each).

If i then reboot, i still see only 1 update, the 10.1 to 10.2 update.

If i then initiate the 10.1 to 10.2 update, it uses a long time, reboots once, then after not a long time it reboots again (Judging by the fan speed).

The result is…It does not update to 10.2, but the 3 other updates i already made, are now back again.

To me this suggests that it rolls back to some previous restore point from before i did the update of the 3 other modules. (Node-Red and 2 others)

Node-Red and the other stayed. I would say you have a corruption happening some where not allowing for the update. You may have to shutdown and pull the 32G SD Card and check it on a computer using HDD health check (Windows). Not sure how to check the 8G Ram.

It may come down to redoing the whole installation.

It is nice you are all chiming in with positive and some less positive experiences. However it is not really giving an answer to the original question. Maye my questions is more a request to the developers to provide more meaningful release notes. Would you like that too?

Home Assistant Operating System Update from 9.5 to 10.2 fails.
I am running it on a Raspberry 4 with 4GB Memory and an external 240GB SSD

The error I am getting is:

Logger: homeassistant.core
Source: components/hassio/update.py:214
First occurred: 16:30:06 (2 occurrences)
Last logged: 17:28:41

Error executing service: <ServiceCall update.install (c:01H1Y879XD53HQKKANA0R4REEV): entity_id=['update.home_assistant_operating_system_update'], version=10.2, backup=False>
Error executing service: <ServiceCall update.install (c:01H1YBJQRBJB63FEF80881MF78): entity_id=['update.home_assistant_operating_system_update'], version=10.2, backup=False>
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/hassio/update.py", line 212, in async_install
    await async_update_os(self.hass, version)
  File "/usr/src/homeassistant/homeassistant/components/hassio/handler.py", line 52, in _wrapper
    raise HassioAPIError(data["message"])
homeassistant.components.hassio.handler.HassioAPIError: Unknown error, see supervisor

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/core.py", line 1867, in catch_exceptions
    await coro_or_task
  File "/usr/src/homeassistant/homeassistant/core.py", line 1889, in _execute_service
    await cast(Callable[[ServiceCall], Awaitable[None]], handler.job.target)(
  File "/usr/src/homeassistant/homeassistant/helpers/entity_component.py", line 226, in handle_service
    await service.entity_service_call(
  File "/usr/src/homeassistant/homeassistant/helpers/service.py", line 798, in entity_service_call
    future.result()  # pop exception if have
  File "/usr/src/homeassistant/homeassistant/helpers/entity.py", line 980, in async_request_call
    await coro
  File "/usr/src/homeassistant/homeassistant/helpers/service.py", line 838, in _handle_entity_call
    await result
  File "/usr/src/homeassistant/homeassistant/components/update/__init__.py", line 156, in async_install
    await entity.async_install_with_progress(version, backup)
  File "/usr/src/homeassistant/homeassistant/components/update/__init__.py", line 417, in async_install_with_progress
    await self.async_install(version, backup)
  File "/usr/src/homeassistant/homeassistant/components/hassio/update.py", line 214, in async_install
    raise HomeAssistantError(
homeassistant.exceptions.HomeAssistantError: Error updating Home Assistant Operating System: Unknown error, see supervisor


Happens exactly the same error with similar setup RPI 4 and SSD drive.

Any insights?
This happens for the second time.
Last time I had to do a clean install with the latest OS version and restore the latest backup.
Very inconvenient.

I have the same issue. Pi 4… update to 10.2 and it goes back to 10.1

Exactly the same experience - did you every figure out what the issue was?

I never found the issue, i stopped trying and now i just have a bunch of updates for various stuff that needs updating.

I am going to just wait until 10.3 and hope it will update to that, and then take it from there. My restarts are now also very slow. (From bootup, until it is reachable via web is sometimes 10-20 minutes…Can ping it, but very slow to load interface).

No worries. In the end i tried a hard reboot of the host and unfortunately it never recovered but instead just boot looped. I then simply re-imaged the disk with 10.2 and then recovered from a backup. It looks like the previous size limit for uploading backups has been removed so it was pretty easy to recover. My backup is around the 1gb size so rebooting once uploaded did take approx 2 hours but she is up and running again now on latest builds of OS and Core.


I actually tried doing a reimage on another SD Card, but after “flashing” the home assistant image onto it and plugging it in, it never came up on the link they said it would, so i gave up, due to time constraints.

I wonder if i can do a backup NOW, and use that to recover, once i get a new fresh instance up and running on a different card.

I was contemplating just making a docker install on my QNAP nas and running it off of that, but i dont want to deal with the faff of it having another IP, compared to the old one.

I have a month old backup as well, if it is impossible to do the new backup and just use that, i can use the 1 month old one, i have not done all that much change since that other than installing updates for the various stuff i have in HA.


Now 10.3 is out, has anyone that was unable to do 10.1 to 10.2 tried to upgrade from 10.1 to 10.3 and if so, how did it go ?

Could do it myself but right now my PI is very slow in every update, so i would rather not have to try, if it did not work.

1 Like

Same question but for mini pc. When i went from 9.5 to 10.1 i lost connection. Is it safe now?

Nevermind, network connection is down again after update. What canni do?
Im not installing again.

Restore a backup?