Home Assistant OS 11.1 Installation Issue - Raspberry pi 4

Dear all,

I’ve tried to install the HA OS 11.1 on my Raspberry Pi 4 4 GB; I’ve installed the Image “haos_rpi4-64-11.1.img.xz” with Pi imager. I get the following error:

[supervisor.host.sound] Can’t update PulseAudio data: Failed to connect to pulseaudio server

[supervisor.docker.interface] Can’t install ghcr.io/home-assistant/aarch64-hassio-cli:2023.10.0: 500 Server Error for http+docker://localhost/v1.43/images/ghcr.io/home-assistant/aarch64-hassio-cli:2023.10.0/json: Internal Server Error (“readlink /mnt/data/docker/overlay2: invalid argument”)
[supervisor.plugins.cli] CLI update failed
[supervisor.plugins.manager] Can’t update cli to 2023.10.0, the Supervisor healthy could be compromised!

Can anyone let me know why the Pi can’t even go through with the installation of the basic image?

Thank you!


Seems the flash was not OK. Try flashing again, or try another SD card

Thank you for your Info!

Did this worked?

I can’t remember how I’ve solved it :wink: but it wasn’t with flashing… I’m usind an SSD Drive not an SD Card - which is way better in performance - but with Pi4 you can only connect it to USB2.0 because the USB3.0 port need some “power” fumbeling in the raspi-config to “allow” more power to the usb. I don’t need it so I’ve stayed at usb2.0