Home Assistant OS Release 5

Thats how it works, yes

‘Suddenly’ I seem to be running an unsupported OS and Systemd. Not a very cool message. All fine, but what am I supposed to do if you’re running 2020.12 on RPI with SD? A clean install and restore latest backup?

The reason we don’t advertise it is because it is just brittle in practice: It needs the right combination of SSD and SSD enclosure as well as RPi 4 firmware. The USB stack (and USB mass storage) is more complex than SD card enumeration, which in the end just leads to more cases where things can go wrong. And they do quite often: Just check the GitHub Home Assistant OS issue tracker, recently most issues stem from USB SSD boot… All this just make USB SSD boot not something we can recommend generally.

We certainly won’t break it on purpose, and address issues where possible. But we cannot make all combinations work… So if your combination works, that is fine! If it doesn’t then you should consider booting off SD card and use datactl command to move just the data partition to the USB SSD drive.


Thank you for detailed and fair explanation.
I can agree with all your points, but I had (and I believe others too) a feeling HA team is heading official SSD boot support since OS 5.0beta. Since v5.8 and after your explanation it seems the team is stepping off this idea.

I currently boot from usb stick (rpi4) with rpi os. And ordered argon one m2 to boot from ssd. I was thinking about going to hassos, because I get “unsupported installation”, and wanted to do it “right”. But, from what I read here, Hassos isn’t ready yet. Booting RPI os from usb gives no problem at all.
Maybe go the RPI OS or Debian os way to boot from usb?

I have a Pi4 8gb, Argon One M.2 and a Kingston SSD A400 120GB M.2 (SA400M8/120G) running Home Assistant OS 5.6.

This setup has been working fine as far as I can tell.


Fan setup


I use a DHT22 temperature sensor using a rPi4 GPIO. It has worked fine for a while but upon installing OS 5.8 it broke. I am getting this message:

dht: Error on device update!
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/entity_platform.py", line 359, in _async_add_entity
    await entity.async_device_update(warning=False)
  File "/usr/src/homeassistant/homeassistant/helpers/entity.py", line 466, in async_device_update
    await task
  File "/usr/local/lib/python3.8/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/components/dht/sensor.py", line 137, in update
  File "/usr/src/homeassistant/homeassistant/util/__init__.py", line 239, in wrapper
    result = method(*args, **kwargs)
  File "/usr/src/homeassistant/homeassistant/components/dht/sensor.py", line 173, in update
    humidity, temperature = self.adafruit_dht.read_retry(self.sensor, self.pin)
  File "/usr/local/lib/python3.8/site-packages/Adafruit_DHT/common.py", line 94, in read_retry
    humidity, temperature = read(sensor, pin, platform)
  File "/usr/local/lib/python3.8/site-packages/Adafruit_DHT/common.py", line 80, in read
    platform = get_platform()
  File "/usr/local/lib/python3.8/site-packages/Adafruit_DHT/common.py", line 63, in get_platform
    raise RuntimeError('Unknown platform.')
RuntimeError: Unknown platform.
1 Like

Guess you had 4.x OS before upgrading. 4.x OS is 32bit and supports GPIO, but 5.x is 64bit and doesn’t support Pi’s GPIO. Can’t understand why 5.8 was marked stable before fixing GPIO.

I really like the look of that case with the fan and the integrated SSD option!

How did you flash the Home Assistant OS to the M.2 Drive?

Does the power button still work when you are running HomeAssistant OS or do you have it set to Always On?

1 Like

I have an RPI 3 with HassOS on a USB stick. No problems booting from USB stick.
But beware of the latest update of HassOS, version 5.8, my RPI got dns problems because of that, and have now downgraded to version 5.7. But booting from USB is no problem.

You’re lucky. I upgraded from 4.13 to 5.8 with a USB SSD and the upgrade bricked it. Downloaded a fresh 5.8 image and that would not boot from any of the USB drives I have, even with the latest bootcode.bin on an SD card.

I’ve reverted to 4.13 for now. I’ll have to read up on splitting the OS and data partitions. Shame I didn’t spot this in the release notes first.

I just received my argon on m2. So i can boot from SSD
My current setup boots from a USB stick with rpi os …
It’s an unsupported installation, says the supervisor… So, i was thinking that for my new install, i would use hassos, but, from what i read here, and other forum messages. I maybe better still use rpi os (of Debian?)

I am now booting from USB with a Kingston 480GB A400 SATA 3 2.5" SDD in a Inateck FE2002 SSD enclosure using Home Assistant OS 5.8. So far no problems.

Has anyone experienced some high cpu consumption with with “systemd-resolved” ?
I’ve been hearing the fan on my home assistant machine more and more recently (since I updated to Home Assistant OS 5?). I’ve started some investigation, shutting down, some addons and integrations 1 by 1 until I installed the glance addon and realized the most cpu demanding process by far was systemd-resolved.
I’ve retarted the host machine and cpu is ok at first but systemd-resolved is slowly increasing again (17% at boot, 55% 20 minutes later, 84% now still counting…).

Any idea where/what I should be looking into now?

Home Assistant OS 5.8
on a Proxmos 6.3-3

Hm, interesting find. Is the log saying something (e.g. journalctl -u systemd-resolved?). Do you have more than one Home Assistant instance running on your network?

Only 1 home assistant instance running on my network and I could not find anything “systemd-resolved” in the logs.
Looks like the cpu graph has changed a bit over the last 2 days to something like this:

The systemd-resolved process seems to be oscilating between 1 and 30% now but the python 3 process is getting fatter I most probably has something creating this behaviour in my config but I haven’t been able to nail it down just yet.
Any clue?

How can I run such system command on Home Assistant OS ? Sorry, I just switch from a docker install to HA OS a few weeks ago.

use the “login” command before running the journalctl command to get to the host os

1 Like

To access the OS shell you can either use the system console (HDMI/keyboard) or using SSH port 22222 (see https://developers.home-assistant.io/docs/operating-system/debugging).

Do you use the 32-bit or the 64-bit version?