Home Assistant OS Release 6

Home Assistant OS 6.0 stable is available now!


  • OS Agent for better OS integration with Supervisor

  • Support for additional Wi-Fi and Bluetooth devices

  • Smaller virtual machine disk images

  • Improved: Generic x86-64 system support

Table of contents

Operating System Changes

OS Agent

Operating System release 6 comes with a new, Go written daemon called OS Agent. This allows the Supervisor to access more aspects of the OS. One such aspect is to move the data to an external data disk or wipe data to start over without reinstalling. Note however that at this point, the required logic in the Supervisor and Frontend is still being developed.

Under the Hood

Under the hood, the OS was updated to the latest upstream Linux 5.10 kernel as well as Buildroot 2021.02.1. The latest Buildroot release brings tons of new software versions along with bug and security fixes. Some key components which received an update were systemd 247 and the Docker Container Engine 20.10.6.

Other Changes

  • The short name of the OS used throughout the software stack was renamed to “haos”. From a users perspective not much changes, but it leads to new file names.
  • The Home Assistant CLI is now started on tty1 instead of the login prompt. The HA CLI banner shows the IP and other device information without the need to attach a keyboard to login.
  • The default shell of the root user is now the Busybox ash. This allows to use scp and similar tools using SSH.
  • The system start is now delayed until the system time has been synchronized with an NTP server. This avoids connection issues to SSL/TLS enabled servers when the system time is off. In practice, the delay should only be a few seconds. The system proceeds with startup after 90s in case the NTP server was not reachable (e.g. if no Internet connectivity is available).

Device Support

Raspberry Pi

All Raspberry Pi versions were updated to use the Linux Kernel 5.10 from the Raspberry Pi team, just like Raspberry Pi OS. The latest Bluetooth firmware for CYW43455 (Raspberry Pi 3 B+/4) with security fixes is now part of the Raspberry Pi images.

Generic x86-64

In Home Assistant OS 6 the board/image “Intel NUC” was renamed to “Generic x86-64”. Existing “Intel NUC” installation will automatically migrate to the “Generic x86-64” image on update.

Already with OS 5 the “Intel NUC” image was usable for most UEFI capable x86-64 systems. With the rename that fact is emphasized. Home Assistant OS is open to changes to add drivers to extend support for other x86-64 platforms. However, keep in mind that we don’t have access to all x86-64 hardware, so support for devices is on a best effort basis.

Other Changes:

  • The Intel IGC network driver supports Intel network cards such as I225-LM/I225-V used on some newer Intel NUC devices.

  • With Home Assistant OS 6 the latest version of the Barebox bootloader 2021.05.0 which fixes boot from hard disks larger than 2TB.

  • The ACPI kernel driver for Thinkpad devices is enabled.

Open Virtualization Appliance

The virtual disk images are now built from a sparse file as source, which leads to smaller effective disk image sizes. Disk images are now also distributed in the more common zip file format (except the qcow2 images which are mostly used on Linux, they continue to be in the xz compression format).

By default, the image now has a serial console enabled which is useful to access Home Assistant OS on headless host systems.

Additional Wi-Fi and Bluetooth Device Support

Ralink rt27xx/rt28xx/rt30xx, as well as Realtek 87xx/88xx devices, are now supported on boards that don’t have onboard Wi-Fi/Bluetooth. This is also true for the OVA image for virtualized environments (when using hardware passthrough functionality). For the OVA image, also Intel firmwares are now part of the image so that Intel Wi-Fi/Bluetooth devices can be used in passthrough mode as well.

Homematic IP Support

@jens-maus contributed OS support for Homematic/Homematic IP dual-stack support for RPI-RF-MOD or HM-MOD-RPI-PCB devices. This together with the RaspberryMatic CCU Add-On offers the full functionality of RaspberryMatic embedded in Home Assistant.

Google Coral PCIe AI Accelerator Support

@ryddler enabled the driver for Google Coral PCIe TPU devices. This allows to use Google Coral Mini PCIe Accelerator or M.2 Accelerator on all boards supporting PCIe.

That’s all Folks! Now go out and update!

This is a companion discussion topic for the original entry at https://www.home-assistant.io/blog/2021/06/11/home-assistant-os-release-6/


The OTA update is trying to connect to https://github.com/home-assistant/operating-system/releases/download/6.0/hassos_ova-6.0.raucb

But the filename on Github is https://github.com/home-assistant/operating-system/releases/download/6.0/haos_ova-6.0.raucb

…hassos… vs …haos…

21-06-11 12:12:33 INFO (MainThread) [supervisor.hassos] Fetch OTA update from https://github.com/home-assistant/operating-system/releases/download/6.0/hassos_ova-6.0.raucb
21-06-11 12:12:34 ERROR (MainThread) [supervisor.hassos] Error raise form OTA Webserver: 404
21-06-11 12:17:28 INFO (MainThread) [supervisor.hassos] Fetch OTA update from https://github.com/home-assistant/operating-system/releases/download/6.0/hassos_ova-6.0.raucb
21-06-11 12:17:28 ERROR (MainThread) [supervisor.hassos] Error raise form OTA Webserver: 404

After a “supervisor reload” it seems te work


A full system reboot sorted it for me, so I’d say the Supervisor was the issue. :+1:

Right, ha supervisor reload should solve the issue

I read about the coral PCIe TPU driver added: I was wondering if the USB one was already there and if Intel iGPU acceleration is enabled for generic x86_64 image.

That would be great for Frigate!

I have a notification about updating to OS6 but when i try to update i get a message saying i’m already on OS6, yet when i reboot etc i still get the update pending notification.
Has anyone got any suggestions ?
Thanks in advance

Home assistant didn’t restart after that OS update, (RPI3B) the USB HDD spins a few seconds at start then stops.
I then tried :

  • clean HDD install OS 6 (several times) → same behaviour
  • boot from SD card containing an old home assistant version → works
  • clean SD card install OS 6 with HDD plugged → loop :
21-06-11 15:57:10 INFO (SyncWorker_4) [supervisor.docker.interface] Updating image homeassistant/raspberrypi3-homeassistant:landingpage to homeassistant/raspberrypi3-homeassistant:2021.6.3
21-06-11 15:57:10 INFO (SyncWorker_4) [supervisor.docker.interface] Downloading docker image homeassistant/raspberrypi3-homeassistant with tag 2021.6.3.
21-06-11 15:58:11 ERROR (SyncWorker_4) [supervisor.docker.interface] Can't install homeassistant/raspberrypi3-homeassistant:2021.6.3: 404 Client Error for http+docker://localhost/v1.41/images/homeassistant/raspberrypi3-homeassistant:2021.6.3/json: Not Found ("no such image: homeassistant/raspberrypi3-homeassistant:2021.6.3: No such image: homeassistant/raspberrypi3-homeassistant:2021.6.3")
21-06-11 15:58:11 WARNING (MainThread) [supervisor.homeassistant.core] Error on Home Assistant installation. Retry in 30sec
  • clean SD card install OS 6 with HDD unplugged → works
  • clean HDD install OS 6 → HDD spins a few seconds then stops or the HDD led stays on and nothing happens.
  • clean HDD install OS 5.13 → same behaviour.
  • clean HDD install OS 5.12 → same behaviour.
  • clean 8GB USB pendrive install OS 6 (test) - The activity LED stays on and nothing happens.
  • reformatting my HDD to FAT32 + install OS 6 → HDD spins a few seconds then stops or the HDD led stays on and nothing happens.
  • Bought brand new SSD + install OS 6 → SSD does exactly the same thing as the HDD.
  • clean SD card install OS 6 + backup restore then thought maybe the USB HUB was the problem so I then :
  • plugged the SSD with OS 6 64bit straight to the USB port of the RPI3B and everything went fantastic, restored backup and all is now fine !

It seems to be a known problem that upgrading a Odroid (like HA Blue) result in the computer not rebooting.
It seems the fix in that case is wait long enough to be sure the installation of the upgrade is done (like 10-15 minutes) and then power cycle the machine.

I think that might also impact some Raspberry Pis. I just did my upgrade and after way longer than I expected it to be back online. I went and turned on the screen. It was just black. No LEDs flashing on the Pi so thought what the hell, I have a backup and power cycled. It started up fine and is now running 6.0 :slight_smile:

The annoying thing is, I didn’t have any trouble updating my test install LOL only when I did it on the production box :frowning:

I just tried updating, but it’s not coming back online. To be safe I waited for 2 hours, then power cycled, but it is still not coming back. Unfortunately my snapshots are a bit old, rather than going back a month, is there anything else worth trying?

Wish I’d read this before updating as it’s the first live OS update I’ve done running on a Pi. Saw black screen with no lights or Ethernet and power cycled. I think I’ve probably borked the update now? At least I made a backup first.

mine doesn’t come back online either. I’m using an SSD. Is it somehow possible to save/recover the data from my SSD so I don’t have to start over again?

Impressed with how robust the update is. Left it turned on for another hour or so and power cycled and it’s up again :slight_smile:

Having said that after checking it’s still on 5.12 so failed bit didn’t kill my install…

If you have an issue with updating continue trying to boot a few times. It should fall back to the previous OS version after the third boot.

1 Like

Same here, didn’t boot up after pressing Update. Power cycled, waiting now. Rpi4. Glad I have the HA Pi on a cloud-based Tuya plug so I can power cycle remotely.

Edit: the update was successful, it just didn’t boot back up afterwards.

The migration went smoothly for me, i.e. no manual reboots.

Has anyone noticed any performance changes after OS migration from 5.12 to 6.0. I am running Rpi4 4GB 64 bit booting off SSD.

Under 5.12 opening an addon log file like ESPHome was pretty well instantaneous, and swap file does not change ie stays close to 0 mB. Total memory usage does really move much around sitting at about 50%.

Under 6.0 opening an addon log file like ESPhome takes about 12 - 15 seconds, and swap file jumped from 200MB to 400MB. Total memory usage is the same and does really move much and sits around 50%. CPU usage spikes a bit, but is under 40%. Opening a couple more logs, and swap file is now up to 750MB

1 Like

after update mine wont boot back up and I have tried rebooting my VM more than three times. Any ideas?

What system are you using? Attaching a screen should give you more insight.