Home Assistant OS update on PI4

I have tried many times and along with many other people different methods to update HA OS from 5.4 to 5.8 - 5.12. Each has failed with the RPI4 on SSD locking up after several hours to a few days. Many people are reporting this on open Github issues (1119 for example). Some have fixed their issue by either changing hardware or change to Debian and putting HA on top. Others have patiently remained on 5.4 hoping for a solution.
The questions are what are we missing by staying on Home Assistant OS 5.4?
Is there a disadvantage / advantage moving to Debian OS and installing Home Assistant on top?

I’m on an RPi4 using HA OS 5.12, with data partition on a USB 3.x SSD. No issues to report here.

Check GitHub 1119. 4G or 8?

I’m on a 4GB model. The SSD is a Sandisk Extreme, model SDSSDE60-1T00. I have it connected to the USB 3.0 ports on the Pi. I’ve been operating in this configuration since July of 2020.

To try to answer your questions in the original post, I think the main thing you lose when you move away from HA OS to e.g. Supervised is the addons functionality; if you want those, then you have to setup and run them yourself, adjacent to HA or on another host. I suspect that performing updates of HA Core also become a manual task in that scenario.

As far as what you’re missing, I’d have to refer you to the changelog. There doesn’t seem to be a CHANGELOG file, but the changes are detailed in the Release section of that repository.

I thought if you run Debian with Home Assistant In “Supervisor mode” all was the same.

Are you using the SD / SSD split?

Yes, I do not have it set to boot from the SSD. I used datactl to switch the Data partition over to the SSD.

I’m probably not the right person to discuss this in detail, since I don’t use this method. I thought that the HA supervisor only existed in deployments with HA OS. The naming for some of these components and scenarios is a little confusing at times.

EDIT: I was wrong; Supervised mode does have a manual install of the supervisor. See https://www.home-assistant.io/installation#compare-installation-methods

Not what I was told by many others. I tried the sd ssd split and it failed also for me. Again no issues on is 5.4 and below.